4

i am just trying to setup PWA studio at my server and i am getting bellow error while run bellow command yarn run watch:venia

    cat: /home/surtexam/.config/devcert/certificate-authority/certificate.cert: No such file or directory
Error: [pwa-buildpack:Utilities:configureHost.js] Could not setup development domain:
Error: Command failed: sudo cat /home/surtexam/.config/devcert/certificate-authority/certificate.cert
cat: /home/surtexam/.config/devcert/certificate-authority/certificate.cert: No such file or directory

    at checkExecSyncError (child_process.js:639:11)
    at Object.execSync (child_process.js:676:15)
    at Object.run (/home/surtexam/public_html/betaone/pwa-studio/node_modules/devcert/dist/utils.js:24:28)
    at LinuxPlatform.<anonymous> (/home/surtexam/public_html/betaone/pwa-studio/node_modules/devcert/dist/platforms/linux.js:81:35)
    at Generator.next (<anonymous>)
    at /home/surtexam/public_html/betaone/pwa-studio/node_modules/tslib/tslib.js:107:75
    at new Promise (<anonymous>)
    at Object.__awaiter (/home/surtexam/public_html/betaone/pwa-studio/node_modules/tslib/tslib.js:103:16)
    at LinuxPlatform.readProtectedFile (/home/surtexam/public_html/betaone/pwa-studio/node_modules/devcert/dist/platforms/linux.js:80:24)
    at Object.<anonymous> (/home/surtexam/public_html/betaone/pwa-studio/node_modules/devcert/dist/certificate-authority.js:86:48)
    at Generator.next (<anonymous>)
    at fulfilled (/home/surtexam/public_html/betaone/pwa-studio/node_modules/tslib/tslib.js:104:62)
    at configureHost (/home/surtexam/public_html/betaone/pwa-studio/packages/pwa-buildpack/dist/Utilities/configureHost.js:165:11)
/bin/sh: line 0: cd: OLDPWD not set

enter image description here

Can any home have idea how to setup on server ? i am using bluehost VPN server for magento 2 and everything setup but not able to run yarn run watch:venia

Anyone please help

1
  • where are your certificates located? is that the right path? Apr 23, 2019 at 5:44

4 Answers 4

2

I faced same issue during installation in local system but it is fixed by just running twice a command in CLI.

yarn buildpack create-custom-origin packages/venia-concept

If You are on Linux than check your certificate in below directory

/etc/ssl

May be it will work for you.

1

I think you have skipped the step 3, of magento documentation,
use

cp packages/venia-concept/.env.dist packages/venia-concept/.env

MAGENTO_BACKEND_URL="https://release-dev-231-npzdaky-zddsyhrdimyra.us-4.magentosite.cloud/
1

Follow all steps mentioned here (https://magento-research.github.io/pwa-studio/venia-pwa-concept/setup/)

I also faced same issue.

Please run using sudo.

And make sure you run command using root user, as their are certain permissions needed.

  • If not try deleting "node_modules" from project root and run "yarn install" again. And then same commands from root user.
4
  • are trying to set up a VPN server or localhost ? all working fine at my localhost i am getting issue only at live server Apr 19, 2019 at 7:38
  • I can suggest that you may contact your server support as this certification issue is related to file permission, as I figured out previously Apr 19, 2019 at 8:29
  • Are you trying with root user ? Did you tried by running with sudo ? In my case it got resolved when I fired same with root user.. Apr 19, 2019 at 8:30
  • yes i tried with root user.... but getting same error Apr 22, 2019 at 6:16
1

Run Magento in developer mode then run these commands in pwa-studio directory.

1. yarn run build
2. yarn run watch:venia

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.