2

I tried to update magento 2.3 to magento 2.3.1, but it failed. I tried to backup from my server and that failed too. How do I roll back the changes to get it to back to 2.3? I followed the steps listed here, and got to step 3. I'm not sure what broke but now the site is down. I am using ubuntu on plesk with lightsail. I do have sudo access and can ssh

EDIT from answer below I am getting the error: rm cannot remove ... Permission denied for a lot of folders. I also got this error when I tried to update.

  • What error it is showing? If u do have a backup of old composer file, put it back and again composer update command ... – Yash Shah Apr 10 at 19:06
  • I'm not sure where I would find that – Morgan Smith Apr 10 at 19:09
  • Its okay if u dont have it, just update here what error it is showing to u ? – Yash Shah Apr 10 at 19:10
  • Do u have sudo user access ? – Yash Shah Apr 10 at 19:14
  • 1
    Yeah ... Must be relaxed now .. 🙂 – Yash Shah Apr 10 at 19:29
4

Try This Command :-

sudo composer require magento/product-community-edition=2.3.0 --no-update

sudo composer update

sudo rm -rf pub/static/frontend/ pub/static/adminhtml/ pub/static/_requirejs pub/static/deployed_version.txt var/cache var/page_cache var/generation var/view_preprocessed var/session generated/code

sudo php bin/magento setup:upgrade

sudo php bin/magento setup:static-content:deploy -f

sudo php bin/magento indexer:reindex

sudo php bin/magento cache:flush
  • any error generate ? – Rk Rathod Apr 10 at 19:07
  • i think error generated for module version ?? – Rk Rathod Apr 10 at 19:08
  • I did a warning that says don't sudo composer though – Morgan Smith Apr 10 at 19:09
  • When I tried to rm -rf I got permission denied (edited question for os stuff) – Morgan Smith Apr 10 at 19:10
  • 1
    most welcome buddy...:) – Rk Rathod Apr 10 at 19:45
-1

as someone said in the comments to sudo chmod -R 777, this is the wrong thing to do if you are in production and causes severe security issues.

you would want to do: directory with 755 and files with 644.

edit:

if your store is 777 a user can come in and change anything they want.

edit 2: "777 is a bad permission in general and I'll show you why. Despite how it may look in a Casino or Las Vegas, 777 doesn't mean jackpot for you. Rather, jackpot for anyone who wishes to modify your files. 777 (and its ugly cousin 666) allow Read and Write permissions (and in the case of 777, Execute) to other. You can learn more about how file permissions work, but in short there are three groups of permissions: owner, group, and other. By setting the permission to 6 or 7 (rw- or rwx) for other you give any user the ability to edit and manipulate those files and folders. Typically, as you can imagine, this is bad for security.

Here's my example:

marco@desktop:~/Projects/AskUbuntu/20105$ cd ..
marco@desktop:~/Projects/AskUbuntu$ chmod 0777 20105
marco@desktop:~/Projects/AskUbuntu$ cd 20105/
marco@desktop:~/Projects/AskUbuntu/20105$ ls -lah
total 8.0K
drwxrwxrwx 2 marco marco 4.0K 2011-01-04 20:32 .
drwxr-xr-x 3 marco marco 4.0K 2011-01-04 20:32 ..
marco@desktop:~/Projects/AskUbuntu/20105$ touch test
marco@desktop:~/Projects/AskUbuntu/20105$ chmod 0666 test

So far I have created a folder and made a file with "bad" permissions (777 and 666). Now I'll switch into another user and try to manipulate those files.

marco@desktop:~/Projects/AskUbuntu/20105$ sudo su - malicious
malicious@desktop:~$ cd /home/marco/Projects/AskUbuntu/20105
malicious@desktop:/home/marco/Projects/AskUbuntu/20105$ ls
test
malicious@desktop:/home/marco/Projects/AskUbuntu/20105$ ls -lah
total 8.0K
drwxrwxrwx 2 marco marco 4.0K 2011-01-04 20:33 .
drwxr-xr-x 3 marco marco 4.0K 2011-01-04 20:32 ..
-rw-rw-rw- 1 marco marco    0 2011-01-04 20:33 test
malicious@desktop:/home/marco/Projects/AskUbuntu/20105$ touch bad
malicious@desktop:/home/marco/Projects/AskUbuntu/20105$ echo "OVERWRITE" > test 
malicious@desktop:/home/marco/Projects/AskUbuntu/20105$ cat test 
OVERWRITE

As this "malicious" user I was able to place files into the directory and inject text into already existent files. Whereas below, in a directory with 755 and files with 644, I am able to see inside files and directories but I can not edit the files nor create new ones:

malicious@desktop:/home/marco/Projects/AskUbuntu/20105$ cd /home/marco/Projects
malicious@desktop:/home/marco/Projects$ touch hey
touch: cannot touch `hey': Permission denied

For Apache permissions, you're going to want to stick to 0755 and 0644 (AKA umask 022) for folders and files respectively. This allows you, as the owner of the files, to edit and manipulate them while giving Apache the bare minimum levels of access needed to operate." - written by user Marco Ceppi (https://askubuntu.com/users/41/marco-ceppi) on thread: https://askubuntu.com/questions/20105/why-shouldnt-var-www-have-chmod-777

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.