0

I tried to update my magento 1.9.3 version to magento 1.9.4.1 by replacing the files by magento 1.9.4.1. After that i am getting an 500 internal server error.

How can I resolve this? I am using cPanel to replace the files.

  • Can you tell us that is written to the logfiles? – torhoehn Apr 9 at 21:06
  • No log files are printing. – remiz_muhammed Apr 10 at 2:47
0

Most probably this is due to file permissions. From the root of your Magento install run:

find . -type f -exec chmod 644 {} \;  
find . -type d -exec chmod 755 {} \;     
find ./var -type d -exec chmod 777 {} \;     
find ./media -type d -exec chmod 777 {} \;

If this works, you should try to lower the permissions a little, this are too permissive but will allow you to check if you are on the right path. If it's working please check this excellent answer for detailed explanation.

  • how can i run these commands from cpanel? – remiz_muhammed Apr 10 at 2:47
  • I am not aware of a simple way of setting permissions recursively through a cPanel. The easiest way is to run those commands in an SSH console. If that is not possible you can achieve the same result by using an FTP client. For example Filezila. In the remote server panel (usually, the right one) right click the Magento root folder and select File Permisions enter 644 in the Numeric values, check Recurse into subdirectories and select apply to files only, click OK Again on Magento root set 755 but select apply to directories only – Dimitar Ivanov Apr 10 at 6:09
  • For var and media select them, enter 777 and apply it to directories and files. If you need some visual reference check - pickaweb.co.uk/kb/… Or if you prefer some other FTP client check how you can set permissions recursively. – Dimitar Ivanov Apr 10 at 6:15
  • Thank you brother!! It worked – remiz_muhammed Apr 10 at 6:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.