When upgrading Magento version 2.2.5 to version 2.2.8 it throws the following error

Problem 1

- Can only install one of: temando/module-shipping-m2[1.3.10, 1.3.7].
- Can only install one of: temando/module-shipping-m2[1.3.10, 1.3.7].
- Can only install one of: temando/module-shipping-m2[1.3.7, 1.3.10].
- magento/product-community-edition 2.2.8 requires temando/module-shipping-m2 1.3.10 -> satisfiable by

temando/module-shipping-m2[1.3.10]. - Installation request for magento/product-community-edition 2.2.8 -> satisfiable by magento/product-community-edition[2.2.8]. - Installation request for temando/module-shipping-m2 (locked at 1.3.7) -> satisfiable by temando/module-shipping-m2[1.3.7].

  • Hi, did you find a solution to this? I've got the same issue at the moment. Jun 4 '19 at 9:06

From the lines that you have posted I would guess that in your composer.json you require the package temando/module-shipping with version constraint 1.3.7 while the package magento/product-community-edition requires a higher version. Check your composer.json for a line similar to:

"temando/module-shipping": "1.3.7"

and either delete it or change it to

"temando/module-shipping": "^1.3.7"

Should this not be the case, you can always check which packages require a specific package in which version by executing the following:

composer why temando/module-shipping
  • 0 thanks for reply i have successfully upgraded version
    – inder
    May 27 '19 at 7:23

Remove This Module Entry in core_config_data Table

And Then Run This Command :-

composer update

composer install

php bin/magento s:up

php bin/magento s:s:d -f

php bin/magento c:f
  • thanks for answer
    – inder
    Apr 10 '19 at 13:26
  • working or not ?
    – Rk Rathod
    Apr 10 '19 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.