3

I have successfully installed Magento 2.3.1 in Xampp. But both the frontend and admin panel of the site are not working.

I have cleared the cache but still, it's not working.

Could anyone please help me with this?

enter image description here

2
  • 1
    you can refer here, this might be related magento.stackexchange.com/questions/255820/… – fmsthird Apr 8 '19 at 8:20
  • 2
    @magefms Thanks you very much. It's perfectly working. Please put this in the answer and i will mark it so that others who encounter this same issue will get output. – Siva Apr 8 '19 at 8:40
3

Try editing the Validator file from vendor folder with namespace

Magento\Framework\View\Element\Template\File

At around line 138 replace code with this one

$realPath = str_replace('\\', '/',$this->fileDriver->getRealPath($path));

save then cache:flush

4
  • never manipulate files in vendor! – Philipp Sander Jul 29 '19 at 9:45
  • @PhilippSander as this is from local dev only and if you are using windows os – fmsthird Jul 29 '19 at 9:47
  • appreciate the downvote tho – fmsthird Jul 29 '19 at 9:47
  • no.... you can edit files in the vendor to test stuff. but it's NEVER a proper fix – Philipp Sander Jul 29 '19 at 9:50
0
  1. This might be caused by your PHP version compatibility with your Xampp.
  2. Try to update the PHP version then try.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.