1

while working with PWA studio venia theme, if we update anything in admin like add a new category or add new product those are not effecting in PWA studio theme instance is there any way that our changes direct reflect on PWA venia theme

4

I have also faced this same issue, although I still need to figure out what is the exact root cause and good solution, but I can suggest you a instant solution that I tried and worked for me.

  1. open pwa-studio/packages/venia-concept/.env
  2. MAGENTO_BUILDPACK_SECURE_HOST_ADD_UNIQUE_HASH=1
  3. Uncomment MAGENTO_BUILDPACK_SECURE_HOST_SUBDOMAIN (remove #) and give a value MAGENTO_BUILDPACK_SECURE_HOST_SUBDOMAIN='narendra'
  4. Run commands:

    yarn run watch:venia

Now you will get a new development instance navigate to the same in an incognito window and check.

What I figured out is that may be there is some sort of caching due to which changes are not reflecting on same url.

  • MAGENTO_BUILDPACK_SECURE_HOST_SUBDOMAIN='narendra' any host file entry is required after changing this? I am getting URL "like 0.0.0.0:8098". Please help. – Kalyan Chakravarthi V Apr 23 at 7:53
  • Try building from root user with sudo and also use secure url I.e. https – Narendra Vyas Apr 24 at 8:03
  • Thanks for the reply. I was doing the same, built with Sudo and https is enabled. Got this message "could not configure or access custom host. using loopback" – Kalyan Chakravarthi V Apr 24 at 8:18
  • You will be in need to provide some more information, better to provide with some screen-shots or the steps that you followed. – Narendra Vyas Apr 24 at 13:23
  • sure will update those details – Kalyan Chakravarthi V Apr 24 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.