4

Customer created order, and all went well. Now I try to ship the product and get this error:

Not all of your products are available in the requested quantity.

I checked and all product are on plenty on stock. 'salable quantity' is also stock minus sold after the order.

6 Answers 6

1

Just checked the product Qty you have in source item table

    mysql-> select * from inventory_source_item where sku = %you sku%;

Just check the product Qty you have in legacy Catalog Inventory Stock Item table

  mysql-> select * from cataloginventory_stock_item where product_id = %your product id% \

If the Qty item is zero in the inventory_source_item update the Quantity item . Then issue will be solved.

2
  • I have checked the product plenty of stock
    – Divya
    Jun 7, 2019 at 8:39
  • There is lots of product which show this error
    – Divya
    Jun 7, 2019 at 9:43
1

We were also experiencing this issue when attempting to ship orders.
Even though we had Stores > Configuration > Catalog | Inventory > Stock Options > Decrease Stock When Order Is Placed set to yes.
This meant Magento was decrementing the stock when the order was placed as well as when creating a shipment.
There is a patch here to fix: https://gist.github.com/adamzero1/cef1cc84c80dae7c4fc8c349178bb639
How To Add/Apply Patches

0

to editors: a question can't be properly answered if not enough information is given. if you choose to delete probing questions, maybe nudge the author to provide more information.

@goodlock is this a fresh install or migrated? what version of magento?

i experienced this on a migrated store, magento v2.3.1 from 1.9.4. i assigned products to a source and opened them for editing then cleared cache. i found that some product's data need formatting like removing trailing spaces on SKUs.

good luck!

0

Magento Have integrated Stock reduce when you Shipped. Make sure the Default quantity and Stock Inventory are available to decrease Quantity.

If not resolved then try to indexing.

php -d memory_limit=15G bin/magento indexer:reindex

0

I have fixed it by saving that product again.

Hope it helps someones!

-1

You could always try disabling MSI. This is useful if you are using an external stock management system. https://www.mexbs.com/magento-blog/disabling-the-magento-msi/

Not the answer you're looking for? Browse other questions tagged or ask your own question.