2

In magento 2.3.0 for new module is throws an exception like below image url http://prntscr.com/n7rpgb

my acl.xml file like this

<?xml version="1.0"?>
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../../../../../lib/internal/Magento/Framework/Acl/etc/acl.xsd">
    <acl>
        <resources>
            <resource id="Magento_Adminhtml::admin">
                <resource id="Ram_Seller::seller" title="Seller" sortOrder="100"/>
 <!--AddMenuAcl-->
            </resource>
        </resources>
    </acl>
</config>
3

Try changing your code as follows

<?xml version="1.0"?>
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:Acl/etc/acl.xsd">
    <acl>
        <resources>
            <resource id="Magento_Backend::admin">
                <resource id="Ram_Seller::seller" title="Seller" sortOrder="100"/>
            </resource>
        </resources>
    </acl>
</config>
2

It says the resource title is missing in your acl.xml file. check sample below:

<?xml version="1.0"?>
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:noNamespaceSchemaLocation="urn:magento:framework:Acl/etc/acl.xsd">
    <acl>
        <resources>
            <resource id="Magento_Backend::admin">
                <resource id="Ram_Seller::seller" title="Seller"
                          translate="title" sortOrder="900"/>
            </resource>
        </resources>
    </acl>
</config>

EDIT: you should use Magento_Backend::admin instead of Magento_Adminhtml::admin in your resource id after resources.

2

Replace your acl.xml with the below code

<?xml version="1.0"?>
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../../../../../lib/internal/Magento/Framework/Acl/etc/acl.xsd">
<acl>
    <resources>
        <resource id="Magento_Backend::admin">
            <resource id="Ram_Seller::seller" title="Seller" sortOrder="100"/>
             <!--AddMenuAcl-->
        </resource>
    </resources>
</acl>
</config>

ISSUE :

The issue with resource id, that's invalid,

It should be Magento_Backend instead of Magento_AdminHtml

0

Just Change :-

From :-

<resource id="Magento_Adminhtml::admin">

To :-

<resource id="Magento_Backend::admin">

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.