If the importer runs with cronjob I get always the same errors on all lines:

Value for 'visibility' attribute contains incorrect value, see acceptable values on settings specified for Admin in line(s):...

If I run the importer manually it always runs without problems. But if it runs automatically with cronjob there are the errors.

I have tried everything. I have tried Integer values, I have tried English strings like "Catalog, Search" and also the same in German.

I have no idea what I can do. Magento version: 2.2.4

4 Answers 4


This is a known issue, see https://github.com/magento/magento2/issues/3923

If the CSV data is in a different language(locale) than the locale of the default store view, the import will fail.

Best way to make sure is to output the valid options, by inserting

$this->_addMessages([print_r($possibleOptions, true)]);

in the validateOption() function of the file magento/vendor/magento/module-catalog-import-export/Model/Import/Product/Validator.php

You will need to use these exact options in the CSV, otherwise the import will fail


"Catalog, Search" is correct value, if you still have issues - it can be one of the following reasons:

  1. If you are import per store view ( as you say German?) check exactly value there and specify on the file
  2. You import file is broken and can't be parsed , check quotes etc.

All you have to do is to provide the visibility value in store language.

For instance, if your store is in deutch, you can do something like

visibility = 'Katalog, Suche' // replacement of "Catalog, Search"


visibility = 'Einzeln nicht sichtbar' // replacement of "Not Visible Individually"

I had the same problem and in the end the problem was that I was adding without space after the comma "Catalog,Search". When I added "Catalog, Search" it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.