2

After I upgraded a Magento 2.2.6 to version 2.2.8, I can not enter the Cache Management and All Users pages anymore. If I click the link in the menu I will be redirected to the dashboard page. Other pages like the Content Pages page or Products page have no problems.

Even if I place die('test') in the execute method of the controller of the page vendor/magento/module-backend/Controller/Adminhtml/Cache/Index.php it redirects to the dashboard. So it should go wrong before it hits this point in the code. But I don't know where to start debugging from there.

7
  • Can you able to find anything in log files? Apr 4 '19 at 11:31
  • Unfortunately nothing is being logged while this happens in the Magento, php error or nginx error log files.
    – M4RT13N
    Apr 4 '19 at 11:41
  • Is nothing in your Magento logs too (system, debug and exception log) Apr 4 '19 at 11:55
  • No, nothing from this problem.
    – M4RT13N
    Apr 4 '19 at 12:13
  • 1
    @RajMohanR Thank you for taking the time to help me investigate this issue. The problem was indeed a third party extension. Luckily I did not needed to disable them all and go through them one by one since user1422208 did point me to the right one.
    – M4RT13N
    Apr 5 '19 at 12:58
-1

Looks like it magento bug in vendor/magento/module-backend/Block/Menu.php protected function _callbackSecretKey($match)

code from 2.3.0 fix it:

protected function _callbackSecretKey($match)
{
    $routeId = $this->routeConfig->getRouteByFrontName($match[1]);
    return \Magento\Backend\Model\UrlInterface::SECRET_KEY_PARAM_NAME . '/' . $this->_url->getSecretKey(
        $routeId ?: $match[1],
        $match[2],
        $match[3]
    );
}

OR you can disable disable Secret Key from Admin URL System -> Configuration -> ADVANCED -> Admin -> Security -> Add Secret Key to URLs = No;

OR SQL:

UPDATE core_config_data SET `value` = 0 WHERE `path` = 'admin/security/use_form_key';
2
  • Your first response solved this problem for us. We indeed had the Mirasvit_Dashboard module installed and removing it fixed this issue. We will contact Mirasvit to solve this problem. Thank you very much!
    – M4RT13N
    Apr 5 '19 at 12:53
  • It not Mirasvit_Dashboard bug. Apr 5 '19 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.