1

I am getting errors when attempting to update Mage_All_Latest 1.9.4.1 via Magento Connect Manager

CONNECT ERROR: Package community/Mage_All_Latest 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Interface_Adminhtml_Default 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Interface_Frontend_Default 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Interface_Install_Default 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Mage_Downloader 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Mage_Centinel 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Interface_Frontend_Base_Default 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Phoenix_Moneybookers 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Mage_Compiler 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Magento_Mobile 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_Cm 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Cm_RedisSession 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Interface_Frontend_Rwd_Default 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Mage_Core_Adminhtml 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Mage_Core_Modules 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_Js_Ext 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_LinLibertineFont 2.8.14.18: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_Js_TinyMCE 3.5.11.17: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_Varien 1.9.4.1 depends on PHP extensions: Array
Package community/Lib_Google_Checkout 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_Js_Calendar 1.51.1.18: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_Js_Mage 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_Phpseclib 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Mage_Locale_en_US 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_Mage 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_Magento 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_Credis 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_Pelago 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_Unserialize 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_IDNA2 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_Mcryptcompat 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_ZF 1.12.10.17: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_Js_Prototype 1.9.4.1: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13
Package community/Lib_ZF_Locale 1.12.10.17: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.2.13

As of 1.9.4.0, Magento is supposed to support PHP 7.2, so why does this update require the older version of PHP?

Can I just change the PHP version locally, update, and push the update to servers running PHP 7.2?

2

I was able to successfully update Magento 1.9.4.0 to 1.9.4.1 using Magento Connect by downgrading PHP to 5.6, performing the update, and then switching the PHP back to 7.2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.