1

I have Magento Community 2.2. installed on managed VPS (Hetzner). I am trying to install component and before installation it starts "Readiness check". All checks out except for:

Check Component Dependency

We found conflicting component dependencies. Hide detail

For additional assistance, see component dependency help .

I don't get any details on error.

WHAT I HAVE TRIED

I have followed instructions from here: https://devdocs.magento.com/guides/v2.2/comp-mgr/trouble/cman/component-depend.html

POSSIBLE CAUSE I was running installation of a module through composer and when asked for authorization (public and private keys) i have saved them in composer.json. Since this is one of possible reasons listed in their documentation (changing of composer.json) all it says is to "edit composer.json" but it doesn't say how or what... I have opened composer.json but I didn't find any keys there...


UPDATE

I have 2 locations for file composer.json:

  • \public_html\composer.json
  • \public_html\var\composer.json

Also have 2 locations for file auth.json:

  • \public_html\composer_home\auth.json
  • \.composer\auth.json

I appreciate help with this :)


Sorry for updates, I am slowly remembering everything I did :)

I have tried to install this: - Iazel_RegenProductUrl - https://github.com/elgentos/regenerate-catalog-urls

I have installed this: - OlegKoval_RegenerateUrlRewrites - https://github.com/olegkoval/magento2-regenerate_url_rewrites

While installing through SSH I had some memory problems and got Killed in process. I found a way to run commands again and installed 1 module listed above.

Module wasn't working as expected so I have tried to install one from Magento Marketplace https://marketplace.magento.com/itcolony-seooverwrite.html. This is where I got error with "Readiness check" and started to investigate on possible causes and solutions.

After that I checked composer.json and saw both modules (Iazel_RegenProductUrl and OlegKoval_RegenerateUrlRewrites) are listed in require: section so I deleted the line where Iazel_RegenProductUrl because I thought it caused problems (since install got killed).

Here it my composer.json:

{
    "name": "magento/project-community-edition",
    "description": "eCommerce Platform for Growth (Community Edition)",
    "type": "project",
    "version": "2.2.7",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "require": {
        "magento/product-community-edition": "2.2.7",
        "composer/composer": "@alpha",
        "olegkoval/magento2-regenerate-url-rewrites": "^1.4"
    },
    "require-dev": {
        "phpunit/phpunit": "~6.2.0",
        "squizlabs/php_codesniffer": "3.2.2",
        "magento/magento2-functional-testing-framework": "2.3.8",
        "phpmd/phpmd": "@stable",
        "pdepend/pdepend": "2.5.2",
        "friendsofphp/php-cs-fixer": "~2.2.1",
        "lusitanian/oauth": "~0.8.10",
        "sebastian/phpcpd": "2.0.4"
    },
    "autoload": {
        "psr-4": {
            "Magento\\Framework\\": "lib/internal/Magento/Framework/",
            "Magento\\Setup\\": "setup/src/Magento/Setup/",
            "Magento\\": "app/code/Magento/"
        },
        "psr-0": {
            "": [
                "app/code/",
                "generated/code/"
            ]
        },
        "files": [
            "app/etc/NonComposerComponentRegistration.php"
        ],
        "exclude-from-classmap": [
            "**/dev/**",
            "**/update/**",
            "**/Test/**"
        ]
    },
    "autoload-dev": {
        "psr-4": {
            "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
            "Magento\\Tools\\": "dev/tools/Magento/Tools/",
            "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
            "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
            "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
        }
    },
    "minimum-stability": "stable",
    "repositories": {
        "0": {
            "type": "composer",
            "url": "https://repo.magento.com/"
        }
    },
    "extra": {
        "magento-force": "override"
    }
}

1

This is according to the documentation.

Typically, component dependency conflicts result from someone manually editing the Magento 2 composer.json file. It can also be caused by third-party modules that depend on earlier Magento components than the ones you have installed. Meaning you have to check the composer.json of the component you are trying to install and determine from its require modules which dependency might be the cause of the issue.

Lastly, authentication keys are saved in auth.json file, not inside composer.json. try to check it you should see your keys there.

  • Thank you. I have updated the question with file locations - it seems I have double files (is that normal?). I am not sure what am I supposed to do with composer.json - should I remove lines where suspicious modules are mentioned? – Oktarin Mar 31 at 10:23
  • Yeah that's normal , but you should only work with those from your Magento root directory, \public_html\composer.json and \public_html\auth.json – fmsthird Mar 31 at 10:37
  • which module are you trying to install when you get the error? probably check from there, open it check its composer.json and look for dependencies that has an old version change it to the latest version and it should work – fmsthird Mar 31 at 10:39
  • I have installed this: github.com/olegkoval/magento2-regenerate_url_rewrites and have tried to install this: github.com/elgentos/regenerate-catalog-urls – Oktarin Mar 31 at 11:34
  • In this https://github.com/elgentos/regenerate-catalog-urls module's composer.json, try to remove everything in require, like leave it as "require": { }, – fmsthird Mar 31 at 11:42
1

auth.jsonis located at ~/.composer/auth.json

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.