0

My Magento version is 1.9.2.2

Which file should I choose between the below given options?

  1. PATCH_SUPEE-11086_CE_1.9.1.0_v1-2019-03-26-03-03-13

  2. PATCH_SUPEE-11086_CE_1.9.2.4_v1-2019-03-26-03-03-50

It's not clear to me..

1

Choose PATCH_SUPEE-11086_CE_1.9.2.4_v1-2019-03-26-03-03-50

  • explain why please – Sam Provides Mar 29 at 10:24
  • This patch is applicable for Magento versions 1.9.1.1 to 1.9.2.4 – Raj Mohan R Mar 29 at 10:30
0

For Magento version 1.9.2.0 to 1.9.2.4 You need to choose PATCH_SUPEE-11086_CE_1.9.2.4_v1-2019-03-26-03-03-50

If you compare both the patches you will find that in patch PATCH_SUPEE-11086_CE_1.9.1.0_v1-2019-03-26-03-03-13 on line number 302 it is looking for the below file

app/code/core/Mage/Adminhtml/Block/System/Design/Edit.php

Now in this file it is looking for the below code to be started from line number 71

     public function getDeleteUrl()
     {
-        return $this->getUrl('*/*/delete', array('_current'=>true));
+        return $this->getUrlSecure('*/*/delete', array(
+            'id' => $this->getDesignChangeId(),
+            Mage_Core_Model_Url::FORM_KEY => $this->getFormKey()
+        ));
     }

But from Magento version 1.9.2.0 to 1.9.2.4 the above code is starting at line number 75 which is given here into the PATCH_SUPEE-11086_CE_1.9.2.4_v1-2019-03-26-03-03-50 at line number 302

So if you will apply the below patch it will not work because it will not be able to find the above code on the line 71.

PATCH_SUPEE-11086_CE_1.9.1.0_v1-2019-03-26-03-03-13

You need to apply the below patch file because it is looking for the above code to be started from the line 75 & from magento version 1.9.2.0 it is present on the line 75.

PATCH_SUPEE-11086_CE_1.9.2.4_v1-2019-03-26-03-03-50

There could be other differences also present I have just compared this one for this time you can check it at your end. You can refer the below file for verifying my answer

magento version 1.9.2.2

magento version 1.9.2.0

magento version 1.9.1.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.