2

I've migrated an old webshop from 1.9 to 2.3.0 and then upgraded to 2.3.1. And I've come across a problem that I can't quite find out why it is happening. There are about 300 products migrated into Magento 2.3, they all have the price of zero. When I try to use the onepage checkout, I get an error at the final step and it stops there.

I've got multiple extensions installed: - Forced Login - Disable Register - Infortis (To edit theme)

Example when I try to checkout: Example 1 I get a 500 error on the path: /index.php/rest/nl/V1/carts/mine/payment-information

With a report saying this error:

Fatal Error: 'Uncaught Error: Call to a member function getAdditionalInformation() on null in domain.nl/public_html/vendor/magento/module-sales/Model/OrderRepository.php:172\nStack trace:\n#0 domain.nl/public_html/vendor/magento/module-sales/Model/OrderRepository.php(134): Magento\Sales\Model\OrderRepository->setPaymentAdditionalInfo(Object(Magento\Sales\Model\Order\Interceptor))\n#1 domain.nl/public_html/vendor/magento/framework/Interception/Interceptor.php(58): Magento\Sales\Model\OrderRepository->get('668')\n#2 domain.nl/public_html/vendor/magento/framework/Interception/Interceptor.php(138): Magento\Sales\Model\OrderRepository\Interceptor->___callParent('get', Array)\n#3 domain.nl/public_html/vendor/magento/framework/Interception/Interceptor.php(153): Magento\Sales\Model\OrderRepository\Interceptor->Mage' in 'domain.nl/public_html/vendor/magento/module-sales/Model/OrderRepository.php' on line 172

I can't find anything about it online and I have no idea how to fix this or what's causing it.

Some other insight I'd be thankful for, if you need any other information, please do not hesitate to ask!

Thank you!

  • I've run into the same kind of problem , and running upgrade, then compile then upgrade then redeploy static content fixed the issue. – fmsthird Mar 29 at 9:05
  • Thank you for your comment, sadly this does not fix it for me. I keep getting the same error. – MrPerry95 Mar 29 at 9:22
  • check maybe you have a third party extension that overrides shipping method or payment method. try to disable or uninstall it first (including removing its data in the database) then check if the issue is gone, then after you can reinstall it again and sure it will work without errors. – fmsthird Mar 29 at 9:24
  • Have you run indexer:reindex command ? – Nauman m. Mansuri Mar 29 at 10:05
  • Yes, I've runned indexer:reindex, though that did not solve the problem. I've uninstalled the three extensions, but that didn't solve it either. The problem persists. – MrPerry95 Mar 29 at 10:28
0

This problem is most likely related to the TIG_PostNL module. You can try to disable it and try again. They are working on Magento 2.3.1 support: https://github.com/tig-nl/postnl-magento2/issues/98

  • I don't have the PostNL extension installed. – MrPerry95 Apr 8 at 11:43
  • Other custom shipping extensions? – Crim Apr 9 at 12:38
  • None installed. – MrPerry95 Apr 12 at 13:41
  • Try to disable all custom shipment/ checkout and payment modules, I fixed this error a couple of times now and it was always related to an extension not compatible with 2.3.1. – Crim Apr 13 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.