0

I've set up a Magento 2.3.0 shop, and I have also translated it. Everything seems fine on the front-end, but one part that I can't get translated, are the .pdf invoices. I have tried to add those words from the invoice into the translate .csv as well, but nothing is working, the invoice is still in English.

  • Try if changing the locale of your admin user and then re-generating the pdf makes a difference. – Kristof at Fooman Mar 29 at 3:32
  • I have upgraded, compiled, deployed, reindexed, clean and still nothing.. – alexcr Mar 29 at 3:41
0

This is a magento2 bug https://github.com/magento/magento2/issues/4409

you can fix it by adding this code to any of your module's di.xml files

<type name="\Magento\Framework\Locale\ResolverInterface">
    <plugin name="mage_localeresolver_reload" type="Magento\Framework\Translate\Locale\Resolver\Plugin" sortOrder="1" disabled="false"/>
</type>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.