1

Please stop me tearing what is left of my hair out.

Magento 2.2.4, two modules installed via composer. Cleared var/page_cache, var/view_preprocessed, var/cache, pub/static, generated/. Then run :

bin/magento setup:upgrade

Modules show up fine in the list that scrolls past. Modules also list as enabled in app/etc/config.php

Then run

bin/magento setup:di:compile
bin/magento cache:clean
bin/magento cache:flush
bin/magento setup:static-content:deploy

The modules show up in pub/static/adminhtml/Magento/backend/en_US and generated/code, but there is absolutely no sign of them in the admin panel itself.

What am I missing? They deploy fine on the dev site which is running the same structure.

1

check in your db under setup_module table, that your module exist or not, if exists check your menu.xml file under [vendor]/[Module]/etc/adminhtml

|improve this answer|||||
  • Both shown in setup_module table. One module creates its own menu item, the other piggybacks on an existing menu item. – Giles Bennett Mar 28 '19 at 10:15
1

Solved. Just realised that I needed flush the PHP OpCache!

|improve this answer|||||
  • You can accept it as your answer Or you can simply update in your question that how you solved this. Good luck – Jai Mar 28 '19 at 14:33
0

check this command:

bin/magento indexer:reindex

after this setup:upgrade then

setup:static-content:deploy

if problem not solve then check this

bin/magento module:status

this show your module enable or disable status.after that your problem not solve then please comment i will futher serve you.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.