0

Having difficulty applying this patch using git apply, as returns missing directories because our magento was installed using composer, so does not have lib/internal/magento.

How can I apply this patch?

2

Change the patch file paths to match with vendor paths.

Ex: for PRODSECBUG-2198-2.3-CE-2019,change path as;

app/code/Magento/Catalog/Model/Product/ProductFrontendAction/Synchronizer.php

to

vendor/magento/module-catalog/Model/Product/ProductFrontendAction/Synchronizer.php

NOTE: make sure to remove precedent "a/" and "b/" from the paths. Do the same for all file paths.

And execute the following command:

composer install --ignore-platform-reqs

If you didn't get hunk errors, check with the related files and observe the patch is applied correctly.


UPDATE:

You can download composer related Patch from below link, under title "Magento Open Source Patches - 2.x". https://www.magentocommerce.com/products/downloads/magento

Ex: PRODSECBUG-2198-2.3-CE.composer.patch

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.