0

I have added this module in Magento 1.9 for stop spam in newsletters.

https://magecomp.com/magento-google-recaptcha.html

This worked fine but, when I try to sign up for the newsletter via curl it works and it should not. It works on a lot of sites under Magento 1.9

curl -vvv -X POST -d "email=titi@test.com" https://www.mysite/newsletter/subscriber/new

How can I block curl requests for newsletter subscriptions?

Thank.

  • you have to enable > admin-login >> System >> Configuration >> Customer >> Newsletter >> > select Yes after check it – Rakesh Donga Mar 25 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.