0

i have disable extension after i can remove extension via composer like this way

php bin/magento module:disable <ExtensionProvider_ExtensionName> --clear-static-content
php bin/magento setup:upgrade
composer remove VendorName/VendorExtensionRepository

but still not working for me
also i have correct credential add but still below error showing

[Composer\Downloader\TransportException] Invalid credentials for 'https://repo.wyomind.com/packages.json', aborting.

enter image description here

  • check credentials – Rk Rathod Mar 20 at 7:05
  • my credentials is correct.. – Rakesh Donga Mar 20 at 7:06
  • which specific module you have? if it's installed using composer, you can remove it using uninstall. – fmsthird Mar 20 at 7:16
  • but it seems an authentication issue – fmsthird Mar 20 at 7:17
  • 2
    Try to uninstall extension php bin/magento module:uninstall Namespace_Modulename and check have you get same error? – Chirag Patel Mar 20 at 7:21
1

the problem is not a module. the problem is that you've added this repository and composer checks which modules are available on this repository, but this check requires you to provide correct credentials.

check your projects composer.json for something like { "type": "composer", "url": "'https://repo.wyomind.com/" }, and remove it.

But keep in mind, that you are no longer able to install modules from this repository.

  • did you add this repository globaly? check ~/.composer/auth.json and remove it from there too – Philipp Sander Mar 20 at 8:40
  • i have above repository in composer.json and again run remove command – Rakesh Donga Mar 20 at 8:41
  • you have to delete the repository. as I said: composer wants to check the repository for packages and this requires you authentication. If you don't want composer to do this, you have to remove the repository everywhere you've added it – Philipp Sander Mar 20 at 8:43
  • means i have not install this extension my previous developer installed it i have only remove in root directory composer.json file – Rakesh Donga Mar 20 at 8:44
  • removing the extension is not enough. you have to remove the repository – Philipp Sander Mar 20 at 8:46
0

[Composer\Downloader\TransportException] Invalid credentials for 'https://repo.wyomind.com/packages.json', aborting.

The error above sometimes occurs during authentication when you are trying to input your public and private key directly on the CLI rather than putting it in auth.json file.

Like below auth.json file pattern

{
    "http-basic": {
        "repo.magento.com": {
            "username":"<your public key>",
            "password":"<your private key>"
        }
    }
}   

And use Magento Uninstall Modules way instead to uninstall a module:

magento module:uninstall [--backup-code] [--backup-media] [--backup-db] [-r|--remove-data] [-c|--clear-static-content] \
{ModuleName} ... {ModuleName}    

Example:

php bin/magento module:uninstall -r <Vendor>_<Module>

-r flag removes module data. Then run afterward the upgrade:

php bin/magento setup:upgrade
  • Thank you for answer but i know this all things but still not working for me – Rakesh Donga Mar 20 at 7:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.