1

I have upgrade apache 2.34 to 2.37. Then I have the problem that all css and js files are only throwing a 500 error and are not loaded. I have got this error on error log: option followsymlinks not allowed here I tried several times to deploy and compile those files and even set up 777 permissions on those files folders but have no luck to get it working.

enter image description here

0

Be sure you have URL rewrites enabled in your Apache config. Here is a tutorial : https://www.digitalocean.com/community/tutorials/how-to-rewrite-urls-with-mod_rewrite-for-apache-on-ubuntu-16-04

This is needed when 'sign static files' is enabled. Also be sure that your allow/disallow settings in your apache site config are set to

 <Directory path/to/magento_root>
                Order allow,deny
                Allow from all
                AllowOverride All
        </Directory>
0

Replace Options +FollowSymLinks to +SymLinksIfOwnerMatch in .htaccess file.

And run this command

find /home -name ".htaccess" -type f -exec sed -i 's/FollowSymLinks/SymLinksIfOwnerMatch/g' {} ";"

it solve my problem

0

You have to add below piece of code in your apache config file.

<Directory />
    Options FollowSymLinks
    AllowOverride Indexes
</Directory>

Adding only on .htaccess file sometimes will not work due to configuration ( AllowOverride None ) of apache config file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.