0

I've upgraded my Magento from 2.2.6 to 2.3, everything went well, but I got some errors.

The first thing I saw in the system.log was something with an attribute, I fixed that. But when I add a product to the shoppingcart I only get to see this:

enter image description here

Translated to English it says: view shipping costs and Tax

What could that be, yesterday I spend almost a day searching for the solution but nothing found :(

The system.log says this:

[2019-03-14 08:01:08] main.INFO: Broken reference: the 'catalog.compare.sidebar' element cannot be added as child to 'sidebar.additional', because the latter doesn't exist [] []
[2019-03-14 08:01:08] main.INFO: Broken reference: the 'wishlist_sidebar' element cannot be added as child to 'sidebar.additional', because the latter doesn't exist [] []
[2019-03-14 08:01:08] main.INFO: Broken reference: the 'sale.reorder.sidebar' element cannot be added as child to 'sidebar.additional', because the latter doesn't exist [] []
[2019-03-14 08:01:08] main.INFO: Broken reference: the 'custom.sidebar.content' element cannot be added as child to 'sidebar.additional', because the latter doesn't exist [] []
[2019-03-14 08:01:08] main.INFO: Broken reference: the 'checkout.cart.item.renderers.gift-card.actions.gift_options' element cannot be added as child to 'checkout.cart.item.renderers.gift-card.actions', because the latter doesn't exist [] []
[2019-03-14 08:01:08] main.INFO: Broken reference: the 'minicart' tries to reorder itself towards 'logo', but their parents are different: 'header-wrapper' and 'header' respectively. [] []
[2019-03-14 08:01:08] main.INFO: Broken reference: the 'custom.sidebar.content' tries to reorder itself towards '', but their parents are different: 'sidebar.additional' and '' respectively. [] []
[2019-03-14 08:01:08] main.INFO: Broken reference: the 'checkout.cart.item.renderers.gift-card.actions.gift_options' tries to reorder itself towards '', but their parents are different: 'checkout.cart.item.renderers.gift-card.actions' and '' respectively. [] []
[2019-03-14 08:01:08] main.INFO: Broken reference: the 'cart.summary' tries to reorder itself towards 'checkout.cart.totals.container', but their parents are different: 'cart.bottom.col2' and 'cart.summary' respectively. [] []

But I have no idea if that has something to do with adding to shoppingcart because every other page is showing normal.

Update:

These were the latest errors in the exception.log (they are fixed)

[2019-03-13 10:12:34] main.CRITICAL: No linked stock found {"exception":"[object] (Magento\\Framework\\Exception\\NoSuchEntityException(code: 0): No linked stock found at /home/bootm2/domains/bootkoffie2.nl/public_html/vendor/magento/module-inventory-sales/Model/GetStockBySalesChannel.php:55)"} []
[2019-03-13 11:58:31] main.CRITICAL: No linked stock found {"exception":"[object] (Magento\\Framework\\Exception\\NoSuchEntityException(code: 0): No linked stock found at /home/bootm2/domains/bootkoffie2.nl/public_html/vendor/magento/module-inventory-sales/Model/GetStockBySalesChannel.php:55)"} []
[2019-03-13 12:00:05] main.CRITICAL: No linked stock found {"exception":"[object] (Magento\\Framework\\Exception\\LocalizedException(code: 0): No linked stock found at /home/bootm2/domains/bootkoffie2.nl/public_html/vendor/magento/module-catalog/Model/Indexer/Product/Price/Action/Full.php:163, Magento\\Framework\\Exception\\NoSuchEntityException(code: 0): No linked stock found at /home/bootm2/domains/bootkoffie2.nl/public_html/vendor/magento/module-inventory-sales/Model/GetStockBySalesChannel.php:55)"} []
[2019-03-13 12:10:04] main.CRITICAL: No linked stock found {"exception":"[object] (Magento\\Framework\\Exception\\LocalizedException(code: 0): No linked stock found at /home/bootm2/domains/bootkoffie2.nl/public_html/vendor/magento/module-catalog/Model/Indexer/Product/Price/Action/Full.php:163, Magento\\Framework\\Exception\\NoSuchEntityException(code: 0): No linked stock found at /home/bootm2/domains/bootkoffie2.nl/public_html/vendor/magento/module-inventory-sales/Model/GetStockBySalesChannel.php:55)"} []
  • check the exception.log , i think there is an error. – Anand Ontigeri Mar 14 at 8:37
  • it seems an issue with a third party extension – magefms Mar 14 at 8:37
  • @AnandOntigeri I've updated the question with the results in the exception.log – n00bly Mar 14 at 8:57
  • Try going into Stores > Inventory > Sources and adding in a source. Maybe call it your business name, then fill in a country and zip value. Then, try going into Stores > Inventory > Stocks. Call it "Default Stock" and apply it to all websites (if multi store) and hit save. After that, see if the issue remains. – Rakesh Donga Mar 14 at 9:00
  • @n00bly working or not? – Rakesh Donga Mar 14 at 9:18
0

You can rename the code folder and run setup:upgrade. Then try to replicate same issue. If no issues there. Just upgrade all extensions to the latest version. Maybe the custom module is the reason for this issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.