3

I've been using Magento shop on an unsecured host for almost a month. I recently setup a secure host(SSL) and directed it to point to same directory as used for unsecured host. But to my surprise, when i try to login to admin panel using secure url, it redirects me to the unsecured one.

I have changed secure_base_url in core_... table, as well as cleared the caches, but its still not working.

Whats happenning ?

Thanks in advance for the help...

5

The redirection back to the login page (with no error) usually means that the session cookie saved was by the wrong domain path.

Try setting your Cookie Domain and make sure that HTTP Only is disabled in Magento.

Do the following:

  1. Go to System > Configuration > Web
  2. Expand Session Cookie Management
  3. Set the following:
    Cookie Path: /
    Cookie Domain: yoursite.com
    Use HTTP Only: No
  4. Save the configuration.

After making configuration changes, flush your Magento Cache, clear your browser cache/cookies and try logging in again.

Not the answer you're looking for? Browse other questions tagged or ask your own question.