0

I am facing this type of error.Unable to access any CLI on Setup. Version Compataible is also match but still no luck.

Parse error: syntax error, unexpected '?', expecting variable (T_VARIABLE)

  • PHP version : 7.2
  • Magento version : 2.3
0

It's php version issue check the reference: https://github.com/magento/magento2/issues/17285

you need to make sure you php version is greater than 7.1.3 in command line by using the command php -v

Check the Magento 2.3 technology stack requirement:

https://devdocs.magento.com/guides/v2.3/install-gde/system-requirements-tech.html

  • Php version is grater than 7.1 using 7.2. I am already mentioned this post. – Anikesh Shahi Mar 13 at 7:40
  • I said because in windows some time person don't set the environment path variable for latest php version. So in command line it will show the older version which once set when first time install wamp and xamp in your system. So regardless you are using greater version but you command line will set to older version that's why I said please run php -v in your command line. if you already check this then may be this issue occur because of some other thing. I will tell one of the possible cause of the issue may be you have other issue just wanted to help :) – Muhammad Hasham Mar 13 at 7:46
  • @Muhmmad,I also checked using this step.environment path is fine.installation too. – Anikesh Shahi Mar 13 at 12:45
  • After checking above step.environment path is correct.but after apply any cli like indexing deploy it show some error . PHP Fatal error: Uncaught Error: Class 'DOMDocument' not found in /vendor/magento/framework/Config/Dom.php:390 – Anikesh Shahi Mar 13 at 12:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.