6

I have installed elasticsearch in my local server successfully.I am not able to reindex the catalog search indexer.Please check attached screenshots.

enter image description here

When i click on the test connection then it shows me successful connection.Please check the configuration and let me know why it does not working?

enter image description here

Do i need to any third party extension to use elasticsearch like smile elastic search or else etc...?

I am using Magento 2.3 version.

1

The _all meta field is now disabled by default

On new mappings, the _all meta field that contains a copy of the text from each field is now disabled by default. The query_string and simple_query_string queries that previously used _all to search will now check if _all is enabled/disabled and switch to executing the query across all fields if _all is disabled. _all can no longer be configured for indices created with Elasticsearch version 6.0 or later.

Multiple mapping types are not supported in indices created in 6.0

The ability to have multiple mapping types per index has been removed in 6.0. New indices will be restricted to a single type. This is the first step in the plan to remove mapping types altogether. Indices created in 5.x will continue to support multiple mapping types.

ElasticSearch docs regarding changes to the _all meta field in v6 for reference: https://www.elastic.co/guide/en/elasticsearch/reference/current/breaking-changes-6.0.html#_the_literal__all_literal_meta_field_is_now_disabled_by_default

Note: Magento Commerce version 2.3.x supports the following Elasticsearch versions:

  • Elasticsearch 5.2.x
  • Elasticsearch 2.x
  • Magento 2.3 uses Elasticsearch PHP client version 5.2. (Before version 2.3, Magento used PHP client version 5.1.)

Reference: https://devdocs.magento.com/guides/v2.3/install-gde/system-requirements-tech.html

I hope this will help

  • Okay let me try to install 5.2.x version instead of 6.6.1 version. – Sunny Rahevar Mar 12 at 11:35
  • @SunnyRahevar any update about issue have you resolve the issue by installing 5.2.x version? – Muhammad Hasham Mar 13 at 5:44
  • I have installed 5.2.x but somehow elasticsearch not started.I have ran all commands for start elasticsearch and when i run this curl -X GET 'localhost:9200' command is shows me connection refused.i have changed host in the elasticsearch.yml file too. But don't know how to fix an error. – Sunny Rahevar Mar 13 at 6:33
  • Please check the elasticsearch install and configure documentation devdocs.magento.com/guides/v2.3/config-guide/elasticsearch/… you may miss something. I am sure, if you successfully install elasticsearch 5.2.x it will resolve your question issue, if my answer helps please mark my answer correct and upvote my answer. thanks – Muhammad Hasham Mar 13 at 6:49
  • Sure.Once it will be done i will mark your answer as correct.Don't worry. Thanks in advance. – Sunny Rahevar Mar 13 at 7:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.