I'm importing a CSV file with new subcategories not already created.
Some times products imported correctly and others it gives me:

general system exception
Asymmetric transaction rollback

Anyone can help?


1 Answer 1


I had this issue recently and tried everything to resolve this.

  • Full reset and manual reindex (completed successfully)
  • Cleared Cache (cache:flush, cache:clean)
  • cleared all static files
  • Changed indexers to run on schedule rather than save
  • Tried setting $this->_isRolledBack to false in Magento/framework/DB/Adapter/Pdo/Mysqlphp rollback()
  • Reset Server, MySql and other services.
  • Tried deleting all products, reindexing and importing
  • full DB restoration

From my research the issue seems to point to a DB error, so I was confident that a full DB restoration would help. But after multiple restoration I still had the issue.

During the course of creating multiple clones, and trying to import products, I was successful on one instance. The difference was I removed all the image locations in my csv. (I had a lot of images with this import) But even if I reduced my product list to 100 it would still get the error. I was successfully able to import my products and later on imported the images in a separate spreadsheet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.