0

We recently moved to a new hosting company and they set our Magento 1.9.1 website as parked on top of the main account's domain. It worked fine for about a week. We haven't made any changes and now we are getting the following Error when trying to access the website:

This page isn’t working `www.ourwebsite.com` is currently unable to handle this request.
HTTP ERROR 500


PHP Fatal error: Uncaught Error: Function name must be a string in /home/account/mydomain.com/includes/src/__default.php:28278    

Stack trace:
    #0 /home/account/mydomain.com/includes/src/__default.php(14070): Mage_Core_Model_Layout->getOutput()
    #1 /home/account/mydomain.com/app/code/local/Smartwave/Ajaxcatalog/controllers/Catalog/CategoryController.php(111): Mage_Core_Controller_Varien_Action->renderLayout()
    #2 /home/account/mydomain.com/includes/src/__default.php(14098): Smartwave_Ajaxcatalog_Catalog_CategoryController->viewAction()
    #3 /home/account/mydomain.com/includes/src/__default.php(18482): Mage_Core_Controller_Varien_Action->dispatch('view')
    #4 /home/account/mydomain.com/includes/src/__default.php(18016): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
    #5 /home/account/mydomain.com/includes/src/__default.php(20808): Mage_Core_Controller_Varien_Front->dispatch()
    #6 /home/account/mydomain.com/app/Mage.php(683): Mage_Core_Model_App->run(Array)
    #7 / in /home/account/mydomain.com/includes/src/__default.php on line 28278

The interesting part of this is that the main website which runs Magento 1.9.4 is up and running with no problems. It's the 2 parked domains/websites that run Magento 1.9.1 that have this issue.

5

It seems you're using the Magento Compiler. You'll need to refresh or disable. In my case, I prefer to disable the Compiler.

The easier way is using Magento shell. Go to the shell directory and then run:

php compiler.php state

Now you'll see the current status of or compiler. If is enabled and/or compiled then please execute these commands:

php compiler.php disable
php compiler.php clear

Now it is disabled and you've cleared all the generated files.

I hope this will help

1

The compilation mode is enabled, thats way you see those errors. Disable compilation: Go into :

includes/config.php

and comment this line

-#define('COMPILER_INCLUDE_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'src');

To get rid of the error you need to disable the compilation in production , and clear the include directory created during compilation includes/src.

php -f shell/compiler.php – clear

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.