I have seen so many answers related to this question but nothing resolved my issue:

enter image description here

I have cleared:

  • cache
  • pub/static
  • generated
  • var/cache,
  • var/view_preprocessed


  • setup:upgrade
  • di:compile
  • cache:flush
  • indexer

Almost run all commands. CSS minfication and JS minfication and merge is also set to 0, means disabled symlink in di.xml file is also set from symlink to copy.

I have tried reverting it to symlink also but no luck. Any other way to sort this out?

In the frontend there are so many console issues like that in the screenshot. Locale is en_US so static-content command is also correct and from the frontend console errors are like this image: enter image description here

  • seems your issue has been fixed:).If you want to post the solution then please put
    – Amit Bera
    Mar 8, 2019 at 7:38
  • issue was not fixed actually , reinstalled theme and import data
    – Flutterer
    Mar 8, 2019 at 15:55

1 Answer 1


I have problems on our site with static content. Cache and upgrade commands are not working quite right. I find that switching the mode to developer and then back to production always remedies it though:

bin/magento deploy:mode:set developer

bin/magento deploy:mode:set production
  • yes i have tried it also but no luck ..
    – Flutterer
    Mar 7, 2019 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.