2

I can't figure out why magento is not loading my template:

enter image description here

The template is located at app/design/frontend/base/default/template/fekete/Newsletter2Go/customer/account/dashboard/info.phtml

I double checked its existence. It does exist on the server.

I executed these two commands to make sure that the permissions are correct:

find . -type d -exec chmod 775 {} \;
find . -type f -exec chmod 664 {} \;

then I ran

chown -R myuser:www *

from the project root. I also cleared the cache. Nothing happens.

I also removed the content from the template and replaced it by this:

Test Test Test

But nothing shows at all even though the template hints reveal that it should render.

UPDATE:

I found this in the log

Not valid template file:frontend/base/default/template/fekete/Newsletter2Go/customer/account/dashboard/info.phtml Not valid template file:frontend/base/default/template/fekete/Newsletter2Go/showOnAllPages.phtml

  • the path shown in the template path hints and mentioned in the question are the same. Are you sure, you have mentioned the correct path of your file in the question? – Mohit Kumar Arora Mar 7 at 9:28
  • Yes of course they are the same. I try to load app/design/frontend/base/default/template/fekete/Newsletter2Go/customer/account/dashboard/info.phtml but nothing shows. I already checked if it does exist on the server under this path and it does. – Black Mar 7 at 9:29
2

I solved it by allowing symlinks. I used n98-magerun to solve it

./n98-magerun.phar config:set dev/template/allow_symlink 1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.