1

We have an issue with load style CSS:

Warning: include(/home/log/domains/domain.com/public_html/generated/code/Magento/Framework/Event/Config/Reader/Proxy.php): failed to open stream: No such file or directory in /home/log/domains/domain.com/public_html/vendor/composer/ClassLoader.php on line 444

Warning: include(/home/log/domains/domain.com/public_html/generated/code/Magento/Framework/Event/Config/Reader/Proxy.php): failed to open stream: No such file or directory in /home/log/domains/domain.com/public_html/vendor/composer/ClassLoader.php on line 444

Warning: include(): Failed opening '/home/log/domains/domain.com/public_html/generated/code/Magento/Framework/Event/Config/Reader/Proxy.php' for inclusion (include_path='/home/log/domains/domain.com/public_html/generated/code:/home/log/domains/domain.com/public_html/generated/code:/home/log/domains/domain.com/public_html/vendor/magento/zendframework1/library:.:/usr/local/php71/lib/php') in /home/log/domains/domain.com/public_html/vendor/composer/ClassLoader.php on line 444

Warning: include(/home/log/domains/domain.com/public_html/generated/code/Magento/Framework/Event/Config/Reader/Proxy.php): failed to open stream: No such file or directory in /home/log/domains/domain.com/public_html/vendor/magento/framework/Code/Generator/Io.php on line 160

Warning: include(/home/log/domains/domain.com/public_html/generated/code/Magento/Framework/Event/Config/Reader/Proxy.php): failed to open stream: No such file or directory in /home/log/domains/domain.com/public_html/vendor/magento/framework/Code/Generator/Io.php on line 160

Warning: include(): Failed opening '/home/log/domains/domain.com/public_html/generated/code/Magento/Framework/Event/Config/Reader/Proxy.php' for inclusion (include_path='/home/log/domains/domain.com/public_html/generated/code:/home/log/domains/domain.com/public_html/generated/code:/home/log/domains/domain.com/public_html/vendor/magento/zendframework1/library:.:/usr/local/php71/lib/php') in /home/log/domains/domain.com/public_html/vendor/magento/framework/Code/Generator/Io.php on line 160

Fatal error: Uncaught Error: Class 'Magento\Framework\Event\Config\Reader\Proxy' not found in /home/log/domains/domain.com/public_html/vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php:111 Stack trace: #0 /home/log/domains/domain.com/public_html/vendor/magento/framework/ObjectManager/Factory/Compiled.php(108): Magento\Framework\ObjectManager\Factory\AbstractFactory->createObject('Magento\\Framewo...', Array) #1 /home/log/domains/domain.com/public_html/vendor/magento/framework/ObjectManager/Factory/Compiled.php(150): Magento\Framework\ObjectManager\Factory\Compiled->create('Magento\\Framewo...') #2 /home/log/domains/domain.com/public_html/vendor/magento/framework/ObjectManager/Factory/Compiled.php(79): Magento\Framework\ObjectManager\Factory\Compiled->get('Magento\\Framewo...') #3 /home/log/domains/domain.com/public_html/vendor/magento/framework/ObjectManager/Factory/Compiled.php(150): Magento\Framework\ObjectManager\Factory\Compiled->create('Magento\\Framewo...') #4 /home/log/domains/ge in /home/log/domains/domain.com/public_html/vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php on line 111

I try to rename folder generated, deploy the system, delete pub/static/ but still, issue. Any solution?

  • Delete genrated/metadata and generated/code and set permission to generated folder then try again. – Sukumar Gorai Mar 6 at 10:17
0

Try running followings in given order.

php bin/magento setup:upgrade
rm -rf var/{cache,di,generation,page_cache,view_preprocessed}
php bin/magento setup:static-content:deploy
php bin/magento setup:di:compile

Go the magento root folder and run this command.

sudo chmod -R 777 generated/
sudo chmod -R 777 var/
  • after run setup:upgrade Warning: include(/home/log/domains/domain.com/public_html/generated/metadata/global.php): failed to open stream: No such file or directory in /home/log/domains/domain.com/public_html/vendor/magento/framework/App/ObjectManager/ConfigLoader/Compiled.php on line 31 – Sylvester Mar 6 at 10:10
  • Deleting var/generation, var/cache and var/di solved it – HIren Kadivar Mar 6 at 10:12
  • After deleted {cache,di,generation,page_cache,view_preprocessed} sill the same issue – Sylvester Mar 6 at 10:18
  • give permission chmod -R 777 var/ pub/static generated/ then it'll work I hope – Prathap Gunasekaran Mar 6 at 10:19
  • @Sylvester please permission to generated and var folder – HIren Kadivar Mar 6 at 10:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.