1

I tried to override the XML file by copying the file from

vendor/magento/module-catalog/view/frontend/layout/catalog_category_view_type_default.xml

to

app/design/frontend/Infortis/base/Magento_Catalog/layout/catalog_category_view_type_default.xml

However, it is still loading the file from the vendor folder. I have tried clear & flush the cache, redeploy static content, but doesn't work.

below is the change i made ( comment out the container)

<?xml version="1.0"?>
<!--
/**
 * Copyright © Magento, Inc. All rights reserved.
 * See COPYING.txt for license details.
 */
-->
<page xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:View/Layout/etc/page_configuration.xsd">
    <body>
        <!--<referenceContainer name="sidebar.main">
            <block class="Magento\Catalog\Block\Navigation" name="catalog.leftnav" before="-" template="Magento_Catalog::navigation/left.phtml"/>
        </referenceContainer>--> <!--remove shop by category from category listing page -->
    </body>
</page>
  • There could be 2 reasons, 1- your theme folder is in correct, ( i.e base ) move your folder to other folder which is actually being used by the theme. 2- Magento_Catalog layout is overriding by another module. – Naveed Asim Mar 5 at 5:59
  • you want to remove sidebar.main allover website? – Rakesh Donga Mar 5 at 6:30
2

If Infortis/base is your theme name (base is a weird name to give to a theme and usually this is written in CamelCase) and you have set your theme up like here then there are certain rules before it will show

  1. Select your theme under Content > Design > Configuration > Select the right store and select Infortis/base there. The theme that you select there is the one that does the xml changes.
  2. In your XML you need to use referenceBlock, referenceContainer or create a new block/container. More documentation here
  3. In developer mode you can check your magento_root/var/log/system.log to check for parents that a block maybe can not find. Be sure that your log level in your nginx or apache settings are set to log all
  4. You should consider load orders. More information here

UPDATE

Commenting out something does not remove anything. You do not 'overwrite' the XML but extend it by using it.

You can however remove something like this :

<referenceContainer name="name-of-the-container" remove="true"/>
<referenceBlock name="name-of-the-block" remove="true"/>
  • my theme name is Infortis/ultimo, which is the child of the infortis/base theme. I also tried to put into the Ultimo folder in app/design/frontend/Infortis/ultimo/Magento_Catalog/layout/, but still not working. I'm only commenting out the "<referenceContainer name="sidebar.main"> ...." in the xml. i will check through the log file. thanks – Kris Wen Mar 5 at 6:11
  • What is it exactly that you have changed in the xml? – CompactCode Mar 5 at 6:20
  • I'm commenting out the "<referenceContainer name="sidebar.main">" container, so that the "Shop By Category" can be remove from the category view page. (Updated my question with the change i made to the xml file) – Kris Wen Mar 5 at 6:26
  • See my updated answer – CompactCode Mar 5 at 6:32
  • that works! thanks a lot. still a lot to learn =) – Kris Wen Mar 5 at 6:35
2

Try to this way...

vendor/magento/module-catalog/view/frontend/layout/catalog_category_view_type_default.xml

to
app/design/frontend/Infortis/ultimo/Magento_Catalog/layout/catalog_category_view_type_default.xml"

Or open this file app/design/frontend/Infortis/ultimo/Infortis_Ultimo/layout/default.xml

and add below code

<referenceBlock name="sidebar.main" remove="true"/>

Please don't forget to clear cache after change in xml files

  • unfortunately, it doesn't work – Kris Wen Mar 5 at 6:06
  • i have checked my side this is working you have which mode in working ? – Rakesh Donga Mar 5 at 6:07
  • i'm on developer mode. should i switch to another mode? – Kris Wen Mar 5 at 6:12
  • no mate you have created file my follow path? also check which theme you are check again – Rakesh Donga Mar 5 at 6:15
  • yes, i created the file using the path you provided. it's pretty weird issue.. – Kris Wen Mar 5 at 6:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.