2

I have recently migrated my site to a new dedicated server and as part of the move have updated the URL to a new one.

I am getting an invalid URI error and have searched the forums and the wider web but only find references to URLs with underscores in them.

Neither the old URL nor the new URL contain any underscores but I get the following error when trying to access any page:

There has been an error processing your request

Invalid URI supplied

Trace:

#0 /var/www/vhosts/sconch.com/httpdocs/lib/Zend/Uri.php(143): Zend_Uri_Http->__construct('http', '/www.sconch.com...')
#1 /var/www/vhosts/sconch.com/httpdocs/app/code/core/Mage/Core/Model/Store.php(773): Zend_Uri::factory('http:/www.sconc...')
#2 /var/www/vhosts/sconch.com/httpdocs/app/code/core/Mage/Core/Controller/Varien/Front.php(332): Mage_Core_Model_Store->isCurrentlySecure()
#3 /var/www/vhosts/sconch.com/httpdocs/app/code/core/Mage/Core/Controller/Varien/Front.php(161): Mage_Core_Controller_Varien_Front->_checkBaseUrl(Object(Mage_Core_Controller_Request_Http))
#4 /var/www/vhosts/sconch.com/httpdocs/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#5 /var/www/vhosts/sconch.com/httpdocs/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#6 /var/www/vhosts/sconch.com/httpdocs/index.php(87): Mage::run('', 'store')
#7 {main}

The URL sconch.com is not yet live but can be accessed by adding the following to a hosts file:

77.240.14.81 sconch.com

77.240.14.81 www.sconch.com

Any help would be greatly appreciated!

Thanks

1
  • Did you update your urls in the core_config_data table? Jul 9 '14 at 13:54
4
  • Should "http:/" not be "http://" ?
  • Is the server migrating from windows to linux? => see Capital Letters usage.
1
  • spotted and corrected this at the same time as your post - must have accidentally deleted one of the slashes when updating the core_config_data table.
    – Hugh
    Jul 9 '14 at 14:20
1

My URL didn't have any underscores "_"

I solved this issue by emptying the contents of the following folders:

  • var/cache
  • var/session

Then refresh your page. That worked for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.