1

I installed the module (https://github.com/mailcampaigns/Magento2Connector) On my Magento (2.3.0 version) application.
It installed successfully but when I try to add a product to the cart.

It's throwing an error on the product page:

We can't add this item to your shopping cart right now.

Error in exception log

main.CRITICAL: Class MailCampaigns\Connector\Helper\MailCampaigns_API does not exist {"exception":"[object] (ReflectionException(code: 0): Class MailCampaigns\Connector\Helper\MailCampaigns_API does not exist at /var/www/html/magento23/vendor/magento/framework/Code/Reader/ClassReader.php:35, ReflectionException(code: 0): Class MailCampaigns\Connector\Helper\MailCampaigns_API does not exist at /var/www/html/magento23/vendor/magento/framework/Code/Reader/ClassReader.php:29)"} []

Is this module not compatible with Magento version 2.3.0 or what can be issues behind this error?

Thanks!

closed as off-topic by Jai, Mohit Kumar Arora, Piyush, Manashvi Birla, Dhiren Vasoya Mar 4 at 7:00

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced OR seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jai, Mohit Kumar Arora, Piyush, Manashvi Birla, Dhiren Vasoya
If this question can be reworded to fit the rules in the help center, please edit the question.

  • we can not support 3rd party modules – Philipp Sander Mar 1 at 14:17
  • have you to run the setup:di:compile command after you successfully installed the external or 3rd party module. – fmsthird Mar 2 at 11:36
  • My application is already in development mode so its not necessary to run such command. – Mr. Nanhe Mar 4 at 5:41