I want to change luma logo but cannot upload the logo ?

I tried to upload through admin panel. But, Not working.


4 Answers 4


You need to change below file



<field name="header_logo_src" formElement="fileUploader">


<field name="header_logo_src" formElement="imageUploader">

and change

<field name="head_shortcut_icon" formElement="fileUploader">


<field name="head_shortcut_icon" formElement="imageUploader">

check this Reference link

  • thanks for your answer. In the link it mentions "app/code/Magento/Theme/view/adminhtml/ui_component/design_config_form.xml" but in my Magento 2.3 there is no code folder in app folder. Also I can't find the file in "vendor" folder. Can you please specify the path to the design_config_form.xml file? Feb 28, 2019 at 10:41
  • This is a bug in 2.3 and patch is available here github.com/magento/magento2/commit/… . code folder you need to manually add, vendor folder you can find right inside main magento folder
    – Anju
    Feb 28, 2019 at 10:48
  • @sannikalariya you need to run below command after code update php bin/magento setup:di:compile
    – VDC
    Feb 28, 2019 at 11:52
  • also command write Feb 28, 2019 at 12:02
  • php bin/magento setup:di:compile
    – VDC
    Feb 28, 2019 at 12:03

Goto Content > Configuration > edit your theme > goto header section upload your logo


Give read write permission on your pub/media directory

chmod -R 755 pub/media
chown -R www-data:www-data pub/media

Then try again

  • I also provide permittion @shoaib Munir Feb 28, 2019 at 11:42
  • Check @Mitrajsinh answer, Goto Content > Configuration > edit your theme > goto header section upload your logo Feb 28, 2019 at 12:04

First run;

bin/magento indexer:reindex 
bin/magento setup:di:compile  
bin/magento cache:clean  
bin/magento cache:flush

and then replace these settings;


Old 154,

field name="header_logo_src" form Element="fileUploader"

to new: 154

field name="header_logo_src" formElement="imageUploader"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.