3

Problem Description: I have created two private repositories in github under same user name. Each repository contains different modules. But while trying to install the package via composer throws error.

Repository 1 : Composer.json

{
  "name": "xxx/module-abc",
  "description": "N/A",
  "type": "magento2-module",
  "version": "1.0.0",
  "autoload": {
    "psr-4": { "VENDOR\\Abc\\": "" },
    "files": [ "registration.php" ]
  }
}

Repository 2: composer.json

{
    "name": "xxx/module-psr",
    "description": "N/A",
    "type": "magento2-module",
    "version": "1.1.0",
    "require": {
        "xxx/module-abc": "*"
    },
    "autoload": {
        "psr-4": { "VENDOR\\Psr\\": "" },
        "files": [ "registration.php" ]
    } 
}

While tring to install to my instance , I have added below code in my Magento root's composer.json composer.json

 "repositories": [
        {
            "type": "composer",
            "url": "https://repo.magento.com/"
        },{"type": "git",
        "url": "https://github.com/xxx/module-psr"}
    ],

Running the below command in terminal composer require xxx/module-psr:dev-master

It throws below error

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for xxx/module-psr dev-master -> satisfiable by xxx/module-psr[dev-master].
    - xxx/module-psr dev-master requires xxx/module-abc * -> no matching package found.

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
 - It's a private package and you forgot to add a custom repository to find it

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Installation failed, reverting ./composer.json to its original content.

Please provide me a solution to install the module via composer

  • I think issue with psr-4 tag, vendor name and module should be capital.(Potential causes:- A typo in the package name) – Pawan Feb 28 at 5:17
  • See i have update the name space but still it throws error – Jaisa Feb 28 at 6:05
  • after updating name, have you update your packagist ? – Pawan Feb 28 at 17:55
  • I have same issue. Did you resolve this issue? If yes, could you advise me? Thanks, – Cát Hạt Aug 26 at 3:13
0

You can specify specific module in you module composer.json like

"require": { 
"php": "^7.0|^7.1", 
"magento/framework": "^101.0",
 },

like you do, but your module "module-abc" got some version "released" (if you are on github self host like the "other post" and only "master branche" you should make a release on github side to be able to get it.

you can also do a composer show xxx/module-abc to see what's version is avaiblable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.