I just updated to 2.3.0 and when I try to open any category page -> instead of filters I am getting "Compare products" and "My wishlist" + . instead of product list getting message "We can't find products matching the selection."

How can I solve/investigate this question?

  • 1
    Reindex & clear cache Commented Feb 27, 2019 at 15:43
  • 1
    i tried, it's not solving Commented Feb 27, 2019 at 15:44

10 Answers 10


Depending on the version you upgraded from it might be a missing stock source/default. Can't check right now but you should find two menu entries under shops or system.


With Magento 2.3 a new feature called Multi Source Inventory was introduced. After an upgrade from a prior version you need to set a source and a default stock. So the settings I mentioned can be found under Stores > Inventory > Sources. Here you need to configure a source. Under Stores > Inventory > Stocks you need to apply default stock to your website.

It may also require a reindex.

  • Where is "Stores" ? Edit: He means "Shops"
    – Black
    Commented Jun 23, 2020 at 15:41

i was facing this challenge and was almost frustrated when i finally got how to fix it. For me I used this

i used the code below to view the table

sql command select *
from catalog_eav_attribute cea 
join eav_attribute ea
  on ea.attribute_id = cea.attribute_id 
  and backend_type in ('text', 'varchar')
  cea.is_filterable = 1

and Set is_filterable to 0 to allow category pages to load.

update catalog_eav_attribute cea 
join eav_attribute ea
  on ea.attribute_id = cea.attribute_id 
  and backend_type in ('text', 'varchar')
set cea.is_filterable = 0
  cea.is_filterable = 1

Reindex/Refresh Cache

magento indexer:reindex
magento cache:clean
magento cache:flush

i got the solution from this link, it was a very helpful solution....thank you doublesharp best solution ever

  • 1
    much appreciated this saved me!
    – SR_Magento
    Commented Oct 3, 2021 at 17:36
  • 1
    Working perfectly Magento2.4.2 Thank you! Commented Jun 6, 2022 at 8:32
  • worked for in 2.4.2, thank you
    – shafiq
    Commented Feb 21, 2023 at 15:32

In my case I tried to re-index but noticed the index failed for esatic search:

Catalog Search index exception: Could not ping search engine: No alive nodes found in your cluster

i resolved by running:

sudo systemctl restart elasticsearch

php bin/magento indexer:reindex

php bin/magento cache:flush

  • worked for me. sudo systemctl restart elasticsearch will work Commented Mar 23, 2021 at 4:22
  • this is it ! Make sure that elasticsearch is running and that magento connects to it (you may test it here: Admin -> Store -> Configuration -> Catalog -> Catalog -> Catalog Search)
    – Fabianus
    Commented Jul 10, 2023 at 19:25

You have to recreate the inventory_Stock_1 view in Database. You can make it happen with an query (like this);

 CREATE OR REPLACE VIEW `inventory_stock_1` AS select
     distinct `legacy_stock_status`.`product_id` AS `product_id`,
     `legacy_stock_status`.`website_id` AS `website_id`,
     `legacy_stock_status`.`stock_id` AS `stock_id`,
     `legacy_stock_status`.`qty` AS `quantity`,
     `legacy_stock_status`.`stock_status` AS `is_salable`,
     `product`.`sku` AS `sku` from
     ( `cataloginventory_stock_status` `legacy_stock_status` join `catalog_product_entity` `product` on
         (( `legacy_stock_status`.`product_id` = `product`.`entity_id` )));

After that, you have to reindex Magento:

php bin/magento indexer:reindex

Now all should be displayed and looks fine.

Hope it helps.

  • This worked for me
    – Christosis
    Commented Aug 22, 2020 at 3:21
  • Work for me ! I had an error message with this particular table.
    – Nico2P
    Commented Oct 12, 2022 at 10:21

Run this command to fix the issue php bin/magento indexer:reindex

  • Does not fix it for me.
    – Black
    Commented Jun 23, 2020 at 15:39
  • me too. I guess the elasticsearch have problem
    – huykon225
    Commented Feb 6, 2021 at 13:34

Run this command to fix the issue php bin/magento indexer:reindex worked for Me


This may sound silly but make sure that both of these are set:

Quantity > 0

Stock Status: In Stock

It may be trivial, but knowing that you must explicitly set "In Stock" even though you've set Qty to a number higher than 0 can save much time.

  • Yes, this happened to me, as Magento 2 noob I spent an enormous amount of time trying to figure it out! Because there is no error in the logs.
    – Duke
    Commented Jun 19, 2023 at 12:16

In Category Enable Anchor in Display Setting.

 Enable Anchor Tag

In Attribute set Filter with Results in Use in Layered Navigation.


And then reindex it. Hope it will work.

  • No, it's not. These steps are dont, but not solve this Commented Feb 28, 2019 at 12:48

On version 2.4.2 if there's an error with your elastic search or if it's not running, then no categories will show. Fix it and run upgrade, di:compile, clear cache again.


I fixed mine by running this command for elastic search:

Step 1: Enable Fielddata Access on the _id Field

curl -X PUT "localhost:9200/_cluster/settings" -H 'Content-Type: application/json' -d'
  "persistent": {
    "indices.id_field_data.enabled": true

Step 2: Verify the Setting

curl -X GET "localhost:9200/_cluster/settings"

Step 3: Reindex Magento

bin/magento indexer:reindex

Step 4: Clear Cache

bin/magento cache:clean
bin/magento cache:flush

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.