0

Product detail page images are not loading. The pointer is just spinning. I have read lots of threads. Clear cache, reindexed, change permissions.

Finally, I got a problem. but unable to fix it. :-/ I am using Porto theme. When I look at the browser console, I see the following error

Uncaught SyntaxError: Unexpected token, in JSON at position 1699
    at JSON.parse (<anonymous>)
    at getNodeData (scripts.js:87)
    at Array.map (<anonymous>)
    at scripts.js:117
    at HTMLDocument.apply (main.js:70)
    at fire (jquery.js:3232)
    at Object.add [as done] (jquery.js:3291)
    at jQuery.fn.init.jQuery.fn.ready (jquery.js:3542)
    at jQuery.fn.init (jquery.js:2967)
    at new jQuery.fn.init (jquery-migrate.js:241)
  • you get more changes of getting an answer to your question if you improve the formatting and make it easier to read. – diazwatson Feb 28 at 16:27
  • Uncaught SyntaxError: Unexpected token , in JSON at position 1699 at JSON.parse (<anonymous>) at getNodeData (scripts.js:87) at Array.map (<anonymous>) at scripts.js:117 at HTMLDocument.apply (main.js:70) at fire (jquery.js:3232) at Object.add [as done] (jquery.js:3291) at jQuery.fn.init.jQuery.fn.ready (jquery.js:3542) at jQuery.fn.init (jquery.js:2967) at new jQuery.fn.init (jquery-migrate.js:241) – Abdullah Feb 28 at 19:46
  • This is a solution but not doesn't work for me magento.stackexchange.com/questions/224642/… – zack71 Mar 13 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.