3

I moved my Magento 2.2.5 based website into another existing site in-order to make them both a multi-site website. I used a paid migration tool and all seemed to go fine, now when I am editing some products to add them to a category for one of my store views I am getting the below error. I even tried deleting the category from the admin panel and then tried for re-creating the category thinking, maybe something with the category just didn't migrate over correctly.

No such entity with id = 128

 Warning: ltrim() expects parameter 1 to be string, array given in vendor/magento/module-catalog/Model/Category/FileInfo.php on line 102

I am not sure how to find out what entity id 128 is . I checked all my other categories which have category images and descriptions added to them all that looks fine.

Any suggestions on how to troubleshoot this further and or how to fix it? I also checked my folder and file permissions already

  • reindexing after migration? – HIren Kadivar Feb 26 at 8:17
  • ya i reindexed, i even compiled and re-deployed – Jayreis Feb 26 at 17:18
  • var/cache/* var/page_cache/* var/view_preprocessed/* var/generation/* – HIren Kadivar Feb 27 at 4:44
  • @Jayreis any solution for this – Pawankumar Jul 4 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.