1

We are using HostGator and they have Magento Community among their Quick Installs. I used their install method, had issues from the start. Nothing they did fixed anything. I had created all of our new categories, products, Amazon s3 download link locations, everything necessary and then in the end, with another HostGator attempt at repairing some Apache files - they accidentally removed our cart.

I had exported the entire product/category structure before asking them to take another look at it, just to be safe. I really didn't want to key that all in again.

I downloaded Magento Community directly from the Magento site, created a new SQL - got it all up and running without any issues whatsoever, till I tried to import the CSV file that Magento itself had created as an export. Upon clicking, "Check Data," on the import screen after selecting the appropriate file, I am returned with the following:

Category does not exists in rows: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43, 44, 45, 46, 47, 48, 49, 50 Product Type is invalid or not supported in rows: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 21, 23, 25, 27, 29, 31, 33, 35, 38, 40, 42, 44, 46, 48, 49, 50 Orphan rows that will be skipped due default row errors in rows: 2, 4, 6, 8, 10, 12, 14, 16, 18, 20, 22, 24, 26, 28, 30, 32, 34, 36, 37, 39, 41, 43, 45, 47

I am hugely confused as to why Magento is not recognizing its own created structure and cells in this CSV file.

The "Category," is clearly present in the table. It most certainly DOES exist in all rows 2-50.

I have no clue why it states Product Type is invalid. All of our current product types are digital download, selected from the Magento default pull down, we had nothing customized with additional attributes or coding.

As far as Orphan rows, all even numbered rows are empty with the exception of having a category cell, as when Magento created the CSV file, it created a secondary row to display the category column for every product which is shown in two categories.

Any ideas as to what I can do to alter the spreadsheet to make it compliant with the import? Also - It states that "Row 1 has no category and it's product type in invalid." Row 1, generated by the Magento export feature, is merely the labels for each column. It shouldn't even be reading the data on line 1.

Trying to avoid having to re-enter all of our products. Any suggestions?

Thanks

  • Hi can you share youre first 50 rows? – Evrijn Jul 8 '14 at 18:28
  • I created a spreadsheet with just that info. Viewable here: strongerman.com/images/example_magento_help.xlsx I was experimenting with some things just as Dataflow-profiles and cannot find anything that will successfully import. I even created a few new widget products, just so I could create an export file to make sure the cells were the same, changed nothing in it, tried to import it back, it said, "Category does not exist in row 1, upload failed." Row 1 - was again, just the labels for the columns. – user9975 Jul 8 '14 at 18:40
  • The default import of Magento is not supporting the import of the downloadable product. You can make it by yourself with this tutorial; jmpmaniacs.wordpress.com/2012/01/10/…; – Evrijn Jul 8 '14 at 19:38
  • Seriously? The default import of Magento, does not support something that is within its default options as product types?? Brilliant. Thanks for the info, but where exactly do I put that? I checked in Advanced Profile for Dataflow and such but am unclear where that php would be running. – user9975 Jul 9 '14 at 17:26
2

The third comment by Evrijn:

The default import of Magento is not supporting the import of the downloadable product. You can make it by yourself with this tutorial: http://jmpmaniacs.wordpress.com/2012/01/10/programatically-import-downloadable-product-from-excel-spreadsheet/

Is as good as this will get, sadly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.