3

I was wondering if anyone could help me. I just upgraded from 1.8.1 to 1.9.1. Everything updated fine along with the database, and it all appeared to be fine.

However, I can no longer view my installed extensions in Connect Manager. I can see all of the Mage core extensions, but none of my community ones. They were all installed using ./mage and previously showed up in 1.8.1, but now it simply cannot see them. They are showing up as modules that I can enable and disable in configuration, but even if I run ./mage list-installed it still can't see them, even though all of the files and folders are in the correct places.

I want to be able to upgrade these extensions via the terminal with ./mage upgrade. Even though I've tried ./mage sync and ./mage sync-pear, it just can't seem to "see" them. Is there something in downloader that has been overwritten by the upgrade which means it can no longer track my community extensions?

Thanks for any help anybody can offer!

Update: What I've done as a fix is I ran ./mage upgrade community extension_name on all of my community extensions (which may not be the solution for some people as they may have a lot more then me!) and instead of moaning about it like it would if I did ./mage install (as it already exists), it simply acts as if it is upgrading it (some actually needed updating, so obviously test them thoroughly afterward).

It then reappears in the extension list on ./mage list-installed and Connect Manager. Yay.

  • Checked var/log? It can give some hints – brainReader Jul 8 '14 at 13:28
  • Thanks for your suggestion.. unfortunately, it doesn't have any relevant information! – littlepixiez Jul 8 '14 at 14:42
  • Ugh, that sounds like a pain in the behind. Might be a bug worth reporting to Magento magentocommerce.com/bug-tracking – Alan Storm Jul 8 '14 at 15:10
  • So that is a bug, report it :) – brainReader Jul 8 '14 at 19:36
2

There's no changes in 1.9 that made Magento Connect stop tracking community extensions. Magento Connect stores a list of your installed extensions in the downloader/cache.cfg file. My guess is something happened during the upgrade (either a Connect Bug or unexpected termination) that reset the list of extensions in this file.

One possible additional diagnostic tool — the latest version of n98-magerun has a command for validating extensions

n98-magerun extension:validate

This command runs through the list of extension in downloader/cache.cfg and compares the cached contents of package.xml with the actual files on your system. Might be useful to see what extensions this command lists as installed vs. what Connect lists as installed.

  • Thank you very much for your suggestion. I wasn't sure exactly how the packages were tracked in Magento. I use git to track only the custom theme files - it doesn't track the downloader folder, so it didn't bring any of those files across when I upgraded Magento.. (I use this method: customerparadigm.com/magento-development/upgrade/…). And sorry to sound dumb, but the package.xml file, where is that? I know it's in var/package/tmp/, but doesn't that get deleted after a while? – littlepixiez Jul 8 '14 at 16:14
  • @littlepixiez My phrasing was awkward earlier, I apologies. The package.xml file you identified is the extension's manifest. The information in this file is also included in the cache.cfg file. The validate command I mentioned uses that information to compare the cached hash from package.xml with the files actually installed. Hope that helps, and don't forget to upvote/accepts answers you like — it'll give you reputation, which helps getting more answers in the future. – Alan Storm Jul 8 '14 at 18:24
1

Move all old files from var/package to new magento var/package folder. Hope it will help to show the extensions there. This solution works for me.

1

I had the same problem here. For me Cache.cfg and connect.cfg had nobody:nobody as the username:group in the downloader/ folder. Here's how I fixed it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.