1

I recently used M2E pro to migrate our ebay orders from our Magento 1 site to our Magento 2 site and I'm now getting some problems with the M2E system.

Firstly we're getting an error at the top of the page reading:

M2E Pro Health Status Notification: Something went wrong with your M2E Pro running and some actions from your side are required. A detailed information you can find in M2E Pro Health Status Center.

The health center shows the following two problems:

eBay Retrieving It seems that there were no orders imported into your M2E Pro during the latest 24 hours which is rather unusual. We strongly recommend you to ensure that there were purchases made on Channel. If the purchases are available on Channel, there might be some issue with your Module running (e.g. failed Install/Upgrade processes, incorrect settings for Magento Cron and inability to use M2E Pro Cron Service, lost connection to M2E Pro Servers, error returned from Channel for Account access, etc.). Thus, please, verify all the aspects related to the Installation/Upgrade and configuration of your M2E Pro Module. It might be helpful to involve your Developer/Administrator into this process along with surfing theDocumentation and Knowledge Base. In case, any assistance is needed, you can consult with our Support Team via email support@m2epro.com.

eBay Magento Order Creation During the last 24 hours, M2E Pro could not create Magento orders for 24 imported Channel orders due to unforeseen issues on Magento side. Please check the Order Logs for more details.

When we click on M2E Pro in "Ebay Integration" and "Listings" We get an error beginning with the following:

Exception #0 (Magento\Framework\Exception\NoSuchEntityException): Requested store is not found
#0 /var/www/vhosts/mywebsitename.com/httpdocs/vendor/magento/module-store/Model/StoreManager.php(167): Magento\Store\Model\StoreRepository->getById(5)
#1 /var/www/vhosts/mywebsitename.com/httpdocs/app/code/Ess/M2ePro/Block/Adminhtml/Ebay/Listing/Grid.php(262): Magento\Store\Model\StoreManager->getStore(5)

As the error mentions getById(5) and getStore(5) I wondered if this had anything to do with the fact that the Ebay store has the following identifiers:

  • 6 for the group ID
  • 6 for the website ID
  • 11 for the default store ID

If this is the case how would we go about changing this so that the ebay system synchronizes with Magento properly?

0

Have spoken to support@m2epro.com.

There was a problem with a removed/not created Store in Magento, which M2E uses in Listings.

They fixed it remotely and changed on default store. It all seems to be working now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.