0

Hi I'm trying to figure out why is it that my custom menu under store->settings->configuration is not displaying when I select the store view. If it's in the Default config its displaying properly but when I select a store view it disappear. May I know why? and how can I have this custom menu display in the system configuration even if I change the store view. Below is my system.xml

<?xml version="1.0"?>
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:module:Magento_Config:etc/system_file.xsd">
    <system>
        <tab id="menu_config" translate="label" sortOrder="100">
            <label>Menu Config</label>
        </tab>
        <section id="mega_menu" translate="label" sortOrder="100" showInDefault="1" showInWebsite="1" showInStore="1">
            <class>separator-top</class>
            <label>Mega Menu</label>
            <tab>menu_config</tab>
            <resource>My_CustomMenu::mega_menu_config</resource>
            <group id="general" translate="label" sortOrder="10" showInDefault="1" showInWebsite="0" showInStore="0">
                <label>Configuration Settings</label>
                <comment>Setup configuration and behavior of the Mega Menu.</comment>
                <field id="dropdown_custom" translate="label" type="select" sortOrder="1" showInDefault="1" showInWebsite="1" showInStore="1">
                    <label>Menu display type</label>                    <source_model>My\CustomMenu\Model\Config\Custom</source_model>
                </field>                        
            </group>
        </section>
    </system>
</config>

This file is located in my module/etc/adminhtml/system.xml

0

Problem is showInWebsite="0" showInStore="0", you need to change that.

Add following code:


<group id="general" translate="label" sortOrder="10" showInDefault="1" showInWebsite="1" showInStore="1">
  • Thanks that fixed it... Can't accept yet need to wait for few minutes – MadzQuestioning Feb 18 at 15:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.