1

added:

"autoload": {
"psr-4": {
  "Magento\\Framework\\": "lib/internal/Magento/Framework/",
  "Magento\\Setup\\": "setup/src/Magento/Setup/",
  "Magento\\": "app/code/Magento/",
  "Zend\\Mvc\\Controller\\": "setup/src/Zend/Mvc/Controller/"
},

composer require magento/product-community-edition=2.3.0 --no-update

composer update

When running this I get below error. Php version 7.1.26

Problem 1
- magento/module-store 100.1.12 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.26) does not satisfy that requirement.
- magento/module-store 100.1.11 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.26) does not satisfy that requirement.
- magento/module-store 100.1.10 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.26) does not satisfy that requirement.
- magento/module-store 100.1.9 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.26) does not satisfy that requirement.

How can I solve this?

0

Try this

php -d memory_limit=-1 /usr/local/bin/composer update --ignore-platform-reqs

--ignore-platform-reqs : ignore php, hhvm, lib-* and ext-* requirements and force the installation even if the local machine does not fulfill these.

3
  • Still same error persists.
    – Trenox
    Feb 18 '19 at 14:45
  • @Trenox updated my answer Feb 18 '19 at 14:48
  • I used the updated version suggestion, not original one.
    – Trenox
    Feb 18 '19 at 14:48
0

Please update your PHP version equal and upper then 7.1.3+.

Please check below Magento official document of support PHP version of M2.3.x.

https://devdocs.magento.com/guides/v2.3/install-gde/system-requirements-tech.html

4
  • My php version is 7.1.26
    – Trenox
    Feb 18 '19 at 15:13
  • it's should be equal or upper then 7.1.3+ and your version 7.1.26. Please check magento system requirements tech link Feb 18 '19 at 15:19
  • I have tried composer update with 7.2 aswell. Same error.
    – Trenox
    Feb 18 '19 at 15:20
  • I am not sure about this but please update the current version of composer and after update into latest 2.3 version. Please try this. composer update bin/magento setup:upgrade --keep-generated Feb 18 '19 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.