2

When i run cli cmds it's take to much time

  >php bin/magento s:s:d -f 



frontend/Magento/luma/en_US             2918/2918           ===100% %  10 mins            
frontend/Solwin/kosmic_child/en_US      3088/3088           == 100% %  44 mins

it's more time and storage

  • Which operating system? – Mohit Kumar Arora Feb 18 at 11:58
  • it's not slow by default , there might be some changes you made that made it slow – fmsthird Feb 18 at 12:12
  • Ubuntu 18......... – prabhakaran7 Feb 18 at 12:21
  • 1
    how are your caches enables/disabled? – Philipp Sander Feb 18 at 12:32
  • enabled......... – prabhakaran7 Feb 18 at 12:42
0

You have two option

  1. run the command with -dmemory_limit=5G

    php -dmemory_limit=5G bin/magento setup:di:compile

  2. Update your local system with SSD drive.

  • i have doubt what is SSD drive – prabhakaran7 Feb 18 at 12:46
  • Like a memory stick, there are no moving parts to an SSD. Rather, information is stored in microchips. Conversely, a hard disk drive uses a mechanical arm with a read/write head to move around and read information from the right location on a storage platter. This difference is what makes SSD so much faster. – Birjitsinh Zala Feb 18 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.