3

I am trying to configure authorize.net payment settings in an magento 2 install. When I edit the payment method values, the default values are reset after I save (i.e. I enable Authorize.net, save and it is disabled).

I tested other payment methods such as braintree and paypal and they all worked fine as expected.

See example screenshots.

Before save - with updated settings input: enter image description here

After save - returned to default or blank. enter image description here

I have not been able to find anything online describing this behavior. Any thoughts?

0

I have a problem which is similar to this.

In system configuration store view I have chosen the Default config and then choose yes on authorize.net enabled payment method.

Then click on save config, which works fine. That configuration was saved.

But now I would change the store view as main webiste, automatically chose no on authorize.net enabled payment method.

And also nearby use default value checkbox was changed to uncheckable.

I'm using magento version2.2.3

And I have tried the authorize.net payment method in one new magento 2.2.3 version package. It working fine.

I don't know exactly. If any other module conflict with this.

I hope your answer is helpful to me.

Thanks in advance.

  • I have fixed this issue. Because in my code there is config save restriction on .htaccess file. @Todd, you can please check your .htaccess file for such type of restriction. – Ramya Jul 18 at 5:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.