0

I am getting an error when uploading a new logo on Valet+

A technical problem with the server created an error. Try again to continue what you were doing. If the problem persists, try again later.

I only see this error in the PHP logs

I tried PHP 7.1 and 7.2 with the same error. Tried jpg, svg, png

Stack trace:
#0 /Users/Shared/html/Magento/magento2.3ee/vendor/magento/framework/Filesystem/Driver/File.php(409): Magento\Framework\Filesystem\Driver\File->deleteFile('/Users/Shared/h...')
#1 /Users/Shared/html/Magento/magento2.3ee/vendor/magento/framework/Filesystem/Driver/File.php(407): Magento\Framework\Filesystem\Driver\File->deleteDirectory('/Users/Shared/h...')
#2 /Users/Shared/html/Magento/magento2.3ee/vendor/magento/framework/Filesystem/Driver/File.php(407): Magento\Framework\Filesystem\Driver\File->deleteDirectory('/Users/Shared/h...')
#3 /Users/Shared/h in /Users/Shared/html/Magento/magento2.3ee/vendor/magento/framework/Filesystem/Driver/File.php on line 383
[13-Feb-2019 21:08:44 UTC] PHP Fatal error:  Uncaught Magento\Framework\Exception\FileSystemException: The "/Users/Shared/html/Magento/magento2.3ee/generated/code/Klarna/Core/Model/Config/Interceptor.php" file can't be deleted. Warning!unlink(/Users/Shared/html/Magento/magento2.3ee/generated/code/Klarna/Core/Model/Config/Interceptor.php): No such file or directory in /Users/Shared/html/Magento/magento2.3ee/vendor/magento/framework/Filesystem/Driver/File.php:383
Stack trace:
#0 /Users/Shared/html/Magento/magento2.3ee/vendor/magento/framework/Filesystem/Driver/File.php(409): Magento\Framework\Filesystem\Driver\File->deleteFile('/Users/Shared/h...')
#1 /Users/Shared/html/Magento/magento2.3ee/vendor/magento/framework/Filesystem/Driver/File.php(407): Magento\Framework\Filesystem\Driver\File->deleteDirectory('/Users/Shared/h...')
#2 /Users/Shared/html/Magento/magento2.3ee/vendor/magento/framework/Filesystem/Driver/File.php(407): Magento\Framework\Filesystem\Driver\File->deleteDirectory('/Users/Shared/h...')
#3 /Users/Shared/html/Magento/magento2.3ee/vendor/ma in /Users/Shared/html/Magento/magento2.3ee/vendor/magento/framework/Filesystem/Driver/File.php on line 383

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.