1

Magento data-migration process all done and all data showing but products add and edit feature not working. when we click on product edit action then we will face issue check below error:

PHP Fatal error: Uncaught TypeError: Argument 2 passed to Magento\Framework\View\Element\UiComponentFactory::argumentsResolver() must be of the type array, null given, called in /var/www/html/magentofirst/vendor/magento/framework/View/Element/UiComponentFactory.php on line 220 and defined in /var/www/html/magentofirst/vendor/magento/framework/View/Element/UiComponentFactory.php:172

Stack trace:

#0 /var/www/html/magentofirst/vendor/magento/framework/View/Element/UiComponentFactory.php(220): Magento\Framework\View\Element\UiComponentFactory->argumentsResolver('file_upload', NULL)
#1 /var/www/html/magentofirst/vendor/magento/module-ui/Component/Form/Field.php(84): Magento\Framework\View\Element\UiComponentFactory->create('file_upload', 'jvs_file', Array)
#2 /var/www/html/magentofirst/vendor/magento/framework/View/Layout/Generator/UiComponent.php(159): Magento\Ui\Component\Form\Field->prepare()
#3 /var/www/html/magentofirst/vendor/magento/framework/View/Layout/Generator/UiComponent.php(156): Mag" while reading response header from upstream, client: 43.240.9.243, server: magentofirst.com, request: "POST /ehplabsc_admin/catalog/product/reload/type/simple/store/0/popup/1/componentJson/1/prev_set_id/16/key/23b5e695b6a69fb96cd248a624282baaea5126f0c9a7e9e8232087140eb6ac42/?set=11&isAjax=true HTTP/1.1", upstream: "fastcgi://unix:/run/php/php7.0-fpm.sock:", host: "http://magentofirst.com", referrer: "http://magentofirst.com/ehplabsc_admin/catalog/product/new/set/16/type/simple/key/6b13831a073eed316c24f915474fcd0f361293882a5ca0ef1898742a51d1777f/"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.