3

Every time I access admin panel I get this error message.

I encountered this problem after I change base_url in core_config_data to http://magento.local/magento/, the previous is http://localhosts/magento/. Anyway I changed it back but the problem still be exist.

Note: Also add "127.0.0.1 magento.local" in host file

Here is a full trace

a:5:{i:0;s:67:"Illegal scheme supplied, only alphanumeric characters are permitted";i:1;s:2782:"#0 C:\xampp\htdocs\Magento\app\code\core\Mage\Core\Model\Store.php(773): Zend_Uri::factory(' `http://localho...`')
1 C:\xampp\htdocs\Magento\app\code\core\Mage\Core\Model\Store.php(607): Mage_Core_Model_Store->isCurrentlySecure()
2 C:\xampp\htdocs\Magento\app\Mage.php(382): Mage_Core_Model_Store->getBaseUrl('skin', NULL)
3 C:\xampp\htdocs\Magento\app\code\core\Mage\Core\Model\Design\Package.php(349): Mage::getBaseUrl('skin', NULL)
4 C:\xampp\htdocs\Magento\app\code\core\Mage\Core\Model\Design\Package.php(503): Mage_Core_Model_Design_Package->getSkinBaseUrl(Array)
5 C:\xampp\htdocs\Magento\app\code\core\Mage\Core\Block\Abstract.php(1035): Mage_Core_Model_Design_Package->getSkinUrl('reset.css', Array)
6 C:\xampp\htdocs\Magento\app\design\adminhtml\default\default\template\login.phtml(32): Mage_Core_Block_Abstract->getSkinUrl('reset.css')
7 C:\xampp\htdocs\Magento\app\code\core\Mage\Core\Block\Template.php(241): include('C:\xampp\htdocs...')
8 C:\xampp\htdocs\Magento\app\code\core\Mage\Core\Block\Template.php(272): Mage_Core_Block_Template->fetchView('adminhtml\defau...')
9 C:\xampp\htdocs\Magento\app\code\core\Mage\Core\Block\Template.php(286): Mage_Core_Block_Template->renderView()
10 C:\xampp\htdocs\Magento\app\code\core\Mage\Adminhtml\Block\Template.php(81): Mage_Core_Block_Template->_toHtml()
11 C:\xampp\htdocs\Magento\app\code\core\Mage\Core\Block\Abstract.php(919): Mage_Adminhtml_Block_Template->_toHtml()
12 C:\xampp\htdocs\Magento\app\code\core\Mage\Core\Block\Text\List.php(43): Mage_Core_Block_Abstract->toHtml()
13 C:\xampp\htdocs\Magento\app\code\core\Mage\Core\Block\Abstract.php(919): Mage_Core_Block_Text_List->_toHtml()
14 C:\xampp\htdocs\Magento\app\code\core\Mage\Core\Model\Layout.php(555): Mage_Core_Block_Abstract->toHtml()
15 C:\xampp\htdocs\Magento\app\code\core\Mage\Core\Controller\Varien\Action.php(390): Mage_Core_Model_Layout->getOutput()
16 C:\xampp\htdocs\Magento\app\code\core\Mage\Adminhtml\controllers\IndexController.php(82): Mage_Core_Controller_Varien_Action->renderLayout()
17 C:\xampp\htdocs\Magento\app\code\core\Mage\Core\Controller\Varien\Action.php(418): Mage_Adminhtml_IndexController->loginAction()
18 C:\xampp\htdocs\Magento\app\code\core\Mage\Core\Controller\Varien\Router\Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('login')
19 C:\xampp\htdocs\Magento\app\code\core\Mage\Core\Controller\Varien\Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
20 C:\xampp\htdocs\Magento\app\code\core\Mage\Core\Model\App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
21 C:\xampp\htdocs\Magento\app\Mage.php(684): Mage_Core_Model_App->run(Array)
22 C:\xampp\htdocs\Magento\index.php(87): Mage::run('', 'store')
23 {main}";s:3:"url";s:25:"/magento/index.php/admin/";s:11:"script_name";s:18:"/magento/index.php";s:4:"skin";s:5:"admin";}
  • Do you have a stacktrace from Magento's error.log to give some more info? – Sander Mangel Jul 7 '14 at 9:24
  • And please make sure you have cleared your cache between changes – Sander Mangel Jul 7 '14 at 9:28
  • Yes I have clear ie cache and magento cache by removing cache folder in Magento\var folder. – user3574149 Jul 7 '14 at 9:39
  • Check this thread stackoverflow.com/questions/7889286/…, your base url should have the full URI Schema so magento.local/magento should work. Be sure to turn of cache to be sure the correct base url is used – Sander Mangel Jul 7 '14 at 9:41
  • Here is a summay step I did 1.change url base to magento.local/magento 2.remove cache 3.disable magento cache by change config in core_cache_option to be 0. The problem still be exist. I'm very new in magento please advice – user3574149 Jul 7 '14 at 9:51
8

Make sure the base_url is a valid URI Schema, so it should be http://magento.local/magento/. Afterwards clear your cache and the issue should be solved.

| improve this answer | |
1

Check your url in core_config_data table it must have http:// with full url like http://smb.virtual.local/~ashwani/www/basemagento/.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.