1

I have freshly installed Magento 2,

And I could not find a way to send the newsletter email,

There are options to queue template, but it is never sent,

and the start date is always different from the one which I set.

What should I do?

NOTE I set email configuration with my credentials.

2 Answers 2

1

Newsletters are sent by a cron job in batches. Have you got your cron jobs set up correctly?

For details of how to setup cron jobs see https://www.mageplaza.com/kb/how-to-configure-cronjob-schedule-tasks-magento-2.html

7
  • Do I still need their extensions?
    – Newb
    Commented Feb 13, 2019 at 12:36
  • No the guide is for default Magento installation. Newsletters can be sent without any need for extensions.
    – ChrisC
    Commented Feb 13, 2019 at 13:35
  • I set up, but no success.
    – Newb
    Commented Feb 13, 2019 at 14:10
  • I would suspect the cron job isn't running. Have you checked your logs to see if it is? In var/system.log I have it stamped: Cron Job newsletter_send_all is run [] []
    – ChrisC
    Commented Feb 14, 2019 at 15:26
  • In the log cron.log about newsletter I found this : ** [2019-02-18 10:49:36] main.INFO: Cron Job newsletter_send_all is missed at 2019-02-18 09:25:00 [] [] ** , sorry for late response.
    – Newb
    Commented Feb 18, 2019 at 10:51
0

You can run command

php bin/magento cron:run

to run Cron manually or set Cronjob to make it run automatically

Note: I had to install SMTP extension (https://www.mageplaza.com/magento-2-smtp/) to send emails from my localhost.

3
  • I success at sending email for forgot the password, but I couldn't do it for the newsletter, cause probably corn isn't run, I think that running command won't have effort because of start date (time) isn't correct, Magento always overrides it with random time.
    – Newb
    Commented Feb 13, 2019 at 12:37
  • Have you set timezone to yours one in Configuration settings? Different timezone cause this issue
    – Khushbu
    Commented Feb 13, 2019 at 12:48
  • Yes, that was the problem, now I set but still no sending, I will use that mageplaza SMTP extension and try.
    – Newb
    Commented Feb 13, 2019 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.