1

I have configured SMTP Magetop - Marketplace Extensions using Sendgrid(Third party service) in M2 site(ver. 2.1.8).

When I trying a test for Gmail, mail is going to spam folder. But when I trying using Zoho, Yahoo and office365 the mail is going to inbox.

I did System > Configuration > Advanced > System > Mail Sending Settings > Set Return-Path to YES

As well as I am tried with Gmail SMTP.

Thanks In advance

1

No matter what you use for sending emails (third party service via SMTP or server PHP Mailer) this not a Magento related issue, but a mail configuration one.

Even if you use Sendgrid, you might have to configure your DNS settings to authenticate the server where Magento is hosted. Best way to find out the exact reasons why your emails end up in spam is to run a test, and the most useful tool I used for this is https://www.mail-tester.com/

  • thanks for your reply.. But other emails providers is going to the inbox. – Shesh Feb 11 at 4:54
  • Each email provider has it's own rules for accepting or rejecting the email. You need to make sure you make all necessary configurations to reduce the changes of emails being rejected – Alex Dinca Feb 11 at 12:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.