2

I managed to migrate magento 1 to new magento 2.2.5 When I reindex for the first time I get in indexer

Category Products

[2019-02-07 21:58:57] main.CRITICAL: Warning: PDOStatement::execute(): MySQL server has gone away in /var/www/html/vendor/magento/zendframework1/library/Zend/Db/Statement/Pdo.php on line 228 {"exception":"[object] (Exception(code: 0): Warning: PDOStatement::execute(): MySQL server has gone away in /var/www/html/vendor/magento/zendframework1/library/Zend/Db/Statement/Pdo.php on line 228 at /var/www/html/vendor/magento/framework/App/ErrorHandler.php:61)"} []

mysql.conf settings are:

[mysqld]
#
# * Basic Settings
#
user            = mysql
pid-file        = /var/run/mysqld/mysqld.pid
socket          = /var/run/mysqld/mysqld.sock
port            = 3306
basedir         = /usr
datadir         = /var/lib/mysql
tmpdir          = /tmp
lc-messages-dir = /usr/share/mysql
skip-external-locking
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address            = localhost
#
# * Fine Tuning
#
key_buffer_size         = 512M
max_allowed_packet      = 1024M
thread_stack            = 192K
thread_cache_size       = 256
connect_timeout=320 # default 10
table_open_cache = 4096
table_definition_cache  = 4096
sort_buffer_size        = 16M
max_heap_table_size     = 512M
tmp_table_size          = 512M
interactive_timeout     = 3600
max_connections         = 400
max_connect_errors      = 1000000
skip_name_resolve
#skip_secure_auth
wait_timeout            = 28800
innodb_buffer_pool_size = 2G
myisam_sort_buffer_size = 128M
innodb_log_file_size    = 256M
innodb_thread_concurrency  = 18
innodb_flush_log_at_trx_commit       = 2
# This replaces the startup script and checks MyISAM tables if needed
# the first time they are touched
myisam-recover-options  = BACKUP
#max_connections        = 100
#table_open_cache       = 64
#thread_concurrency     = 10
#
# * Query Cache Configuration
#
query_cache_limit       = 1M
query_cache_size        = 64M
query_cache_type        = 1

Tried to increase the limits in mysql with no luck. Any suggestions please?

  • what are your MySQL configuration parameters for wait_timeout, max_allowed_packet, tmp_table_size and max_heap_table_size? – HelgeB Feb 8 '19 at 8:23
  • HelgeB I edited the post with my settings – G. G. Feb 8 '19 at 8:28
  • 1
    Additional information request. Post on pastebin.com and share the links. RAM size of your MySQL Host server Text results of: B) SHOW GLOBAL STATUS; after minimum 24 hours UPTIME C) SHOW GLOBAL VARIABLES; D) SHOW FULL PROCESSLIST; E) complete MySQLTuner report AND Optional very helpful information, if available includes - htop OR top OR mytop for most active apps, ulimit -a for a linux/unix list of limits, iostat -xm 5 3 for IOPS by device and core/cpu count, df -h for a linux/unix free space list by device, for server tuning analysis. – Wilson Hauck Feb 28 '19 at 1:16
  • 1
    Glad you are back together. Providing the information requested yesterday will allow meaningful suggestions to improve your system performance. Why are are you allowing hacker/cracker 1 million attempts to guess a password with the max_connect_errors at 1 million? – Wilson Hauck Feb 28 '19 at 21:30
  • 1
    @G.G. With secondary review of your config, it looks like you accidentally have innodb_log_buffer_size much larger than innodb_log_file_size. The buffer should always be smaller than the log_file_size. Sorry I missed this earlier. Still willing to help with tuning, if SHOW GLOBAL STATUS; and SHOW GLOBAL VARIABLES; could be posted, even for DEV or PROD instance. – Wilson Hauck Mar 16 '19 at 22:20
0

I managed to solved this. Problem was not really on mysql. Problem was because of wrong in the migration process. Although I got no errors there. This migration was the uber migration tool.

When did the process from start with magento native migration tool mysql and indexers are fine. Everything is working now

  • I am getting same, how can i face this error? @G.G. – zus Nov 13 '19 at 11:19
  • @zus What exactly you mean? Explain more please... – G. G. Nov 13 '19 at 21:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.